简单树形dp——hdu1520没有上司的晚会

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings. 

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0

Output

Output should contain the maximal sum of guests' ratings. 

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

其实就是一个简单地的树形dp模型,根据它的父子关系,来构建出入度,然后从入度为0的点进行dp

代码

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<vector>
#include<cstdlib>

using namespace std;

const int maxn=60010;
int dp[maxn][2];//dp[i][0or1]表示第i个人去或者不去,0是去,1是不去。
int h[maxn];
int in[maxn];//入度
vector<int>Rt[maxn];//用于储存父子关系,也就是第i个节点跟哪个节点相连。

void  dfs(int u)
{
    dp[u][0]=0;
    dp[u][1]=h[u];
    for(int i=0;i<Rt[u].size();i++)
    {
        dfs(Rt[u][i]);
        dp[u][0]+=max(dp[Rt[u][i]][0],dp[Rt[u][i]][1]);//如果这个人来的话,那么就计算它的直系下属不来的情况。
        dp[u][1]+=dp[Rt[u][i]][0];//写反了,如果他来的话就计算它的直系下属来或者不来的最大值,然后返回
    }
}

void ini()
{
    memset(dp,0,sizeof(dp));
    memset(in,0,sizeof(in));
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        ini();
        for(int i=1;i<=n;i++) scanf("%d",&h[i]);
        for(int i=0;i<n-1;i++)
        {
            int l,k;
            scanf("%d%d",&l,&k);
            Rt[k].push_back(l);
            in[l]++;
        }
        int x,z;
        scanf("%d%d",&x,&z);
        int u=0;
        for(int i=1;i<=n;i++)
        {
            if(in[i]==0) {
                u=i;
                break;
            }
        }
        dfs(u);
        printf("%d\n",max(dp[u][0],dp[u][1]));
        for(int i=1;i<=n;i++) Rt[i].clear();
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41670466/article/details/81570125