To Add Which?

    There is an integer sequence with N integers. You can use 1 unit of cost to increase any integer in the sequence by 1.
    Could you tell us the least units of cost to achieve that, the absolute value of difference between any two adjacent integers is not more than D?

Input

    The first line has one integer T, means there are T test cases.
    For each test case, the first line has two integers ND (1 <= N <= 105, 0 <= D < 109), which have the same meaning as above. The next line has N integers describing the sequence. Every integer in this sequence is in range [0, 109).
    The size of the input file will not exceed 5MB.

Output

    For each test case, print an integer in one line, indicates the desired answer.

Sample Input

3
5 2
1 3 5 3 5
5 1
1 2 3 5 6
5 2
1 7 3 5 9

Sample Output

0
3
8
对n个数操作,每次操作可以加一,问需要多少次
操做才能让每一个数与相邻的数的差不超过d;

先从左开始扫描,不符合要求的进行最小幅度的操作
将扫描后的n个数放入一个新的数组
然后再从右开始扫描,同上。

再扫描以次,从左右两次扫描中选择改变幅度大的哪个数作为
最终的改变结果。
#include<iostream>
#include<cstdio>
#define M 100100
using namespace std;
int num[M],Max[M],Min[M];
int main()
{
    int T,n,D;
    long long ans;
    cin>>T;
    while(T--){
        ans=0;
        cin>>n>>D;
        for(int i=0;i<n;i++) cin>>num[i];

        Max[0]=num[0];
        for(int i=1;i<n;i++)
        {
            if(Max[i-1]-num[i]>D)
                Max[i]=Max[i-1]-D;
            else Max[i]=num[i];
        }

        Min[n-1]=num[n-1];
        for(int i=n-2;i>=0;i--)
        {
            if(Min[i+1]-num[i]>D)
                Min[i]=Min[i+1]-D;
            else Min[i]=num[i];
        }

        for(int i=0;i<n;i++) ans+=(max(Min[i],Max[i])-num[i]);
        cout<<ans<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Cworld2017/article/details/81745235
今日推荐