杭电多校第六场 oval-and-rectangle(数学积分)

oval-and-rectangle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 876    Accepted Submission(s): 380


 

Problem Description

Patrick Star find an oval.

The half of longer axes is on the x-axis with length a.

The half of shorter axes is on the y-axis with length b.

Patrick Star plan to choose a real number c randomly from [0,b], after that, Patrick Star will get a rectangle :

1. The four vertexes of it are on the outline of the oval.

2. The two sides of it parallel to coordinate axis.

3. One of its side is y=c.

Patrick Star want to know the expectations of the rectangle's perimeter.

 

Input

The first line contain a integer T (no morn than 10), the following is T test case, for each test case :

Each line contains contains two integer a, b (0<b<a<105). Separated by an white space.

 

Output

For each test case output one line denotes the expectations of the rectangle's perimeter .

You should keep exactly 6 decimal digits and ignore the remain decimal digits. 

It is guaranted that the 7-th decimal digit of answer wont be 0 or 9.

 

Sample Input

 

1 2 1

 

Sample Output

 

8.283185

 

Source

2018 Multi-University Training Contest 6

 

Recommend

chendu   |   We have carefully selected several similar problems for you:  6373 6372 6371 6370 6369 

 

Statistic | Submit | Discuss | Note

 

积分

#include <bits/stdc++.h>

using namespace std;

#define pi acos(-1.0)

int main(void)
{
    int T;
    cin >> T;
    double ans;
    while(T--) {
        double a,b;
        cin >> a >> b;
        ans = a * pi + 2 * b;
        ans -= 0.0000005;
        printf("%.6lf\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/GYH0730/article/details/81571502
今日推荐