C++:HDU1004 Let the Balloon Rise

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 138295    Accepted Submission(s): 54626


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input
 
  
5 green red blue red red 3 pink orange pink 0
 

Sample Output
 
  
red pink
 

Author
WU, Jiazhi
 

Source

ZJCPC2004


解题思路:这题的大致意思是给你 n 个气球的的颜色,找出哪个颜色最多。我的想法是把每次颜色存入一个结构体中,在输入过程中跟前面的输入比较,如果有这个颜色了就让第一次出现这个颜色的气球的个数加 1 ,然后循环 i 减 1 ,覆盖上次输入,最后结构体中存的就是每种颜色的气球及其个数,然后找出个数最多的输出即可,具体看代码。


代码:

#include<bits/stdc++.h>//包含所有C++头文件
using namespace std;
int main()
{
    int n;
    while(~scanf("%d",&n)&&n!=0)//当n为0时输入结束
    {
    struct balloon
    {
        char s[20];
        int a=1;//a为气球个数,初始化为1
    }b[1005];
    int max,m,f;
    for(int i=0,k=0;k<n;i++,k++)//k判断输入次数,i用来覆盖重复的
    {
        scanf("%s",&b[i].s);
        for(int j=0;j<i;j++)//从0到i-1循环比较
        {
            if(strcmp(b[i].s,b[j].s)==0)
            {
                b[j].a++;
                i--;//覆盖上次输出
                break;
            }
        }
        f=i;//记录颜色种数
    }
    max=b[0].a;m=0;
    for(int i=1;i<=f;i++)
    {
        if(b[i].a>max)
        {
            max=b[i].a;
            m=i;
        }
    }
    cout<<b[m].s<<endl;
    }
}

猜你喜欢

转载自blog.csdn.net/qq_40907345/article/details/79871822
今日推荐