Hex-a-bonacci

Given a code (not optimized), and necessary inputs, you have to find the output of the code for the inputs. The code is as follows:
int a, b, c, d, e, f;
int fn( int n ) {
if( n == 0 ) return a;
if( n == 1 ) return b;
if( n == 2 ) return c;
if( n == 3 ) return d;
if( n == 4 ) return e;
if( n == 5 ) return f;
return( fn(n-1) + fn(n-2) + fn(n-3) + fn(n-4) + fn(n-5) + fn(n-6) );
}
int main() {
int n, caseno = 0, cases;
scanf(“%d”, &cases);
while( cases– ) {
scanf(“%d %d %d %d %d %d %d”, &a, &b, &c, &d, &e, &f, &n);
printf(“Case %d: %d\n”, ++caseno, fn(n) % 10000007);
}
return 0;
}
Input
Input starts with an integer T (≤ 100), denoting the number of test cases.
Each case contains seven integers, a, b, c, d, e, f and n. All integers will be non-negative and 0 ≤ n ≤ 10000 and the each of the others will be fit into a 32-bit integer.
Output
For each case, print the output of the given code. The given code may have integer overflow problem in the compiler, so be careful.
Sample Input
5
0 1 2 3 4 5 20
3 2 1 5 0 1 9
4 12 9 4 5 6 15
9 8 7 6 5 4 3
3 4 3 2 54 5 4
Sample Output
Case 1: 216339
Case 2: 79
Case 3: 16636
Case 4: 6
Case 5: 54

这道题最优的方案就是用dp。

题意:给你一组数据的前6组,让你求出第N个数;满足关系:fn(n)= fn(n-1) + fn(n-2) + fn(n-3) + fn(n-4) + fn(n-5) + fn(n-6) ,数据对10000007取余。
用数组去记录每一个数据,直接输出N即可,但是切记要取余。
由于数据范围较大,必须用long long
代码如下:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
const int maxn=10000007;//取余数字
long long r[100010];//尽量把数组开大些,范围大些
int main(){
    long long num,N;
    scanf("%lld",&num);
    long long key=1;
    while(num--){
        memset(r,0,sizeof(r));
        scanf("%lld%lld%lld%lld%lld%lld%lld",&r[0],&r[1],&r[2],&r[3],&r[4],&r[5],&N);
        for(int i=6;i<=N;i++){
            r[i]=r[i-1]+r[i-2]+r[i-3]+r[i-4]+r[i-5]+r[i-6];
            r[i]%=maxn;
        }
        printf("Case %lld: %lld\n",key,r[N]%maxn);
        key++;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/liubang00001/article/details/81569387
hex