2018 Multi-University Training Contest 6: A. oval-and-rectangle(数论)

 

oval-and-rectangle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0

Problem Description

Patrick Star find an oval.

The half of longer axes is on the x-axis with length a.

The half of shorter axes is on the y-axis with length b.

Patrick Star plan to choose a real number c randomly from [0,b], after that, Patrick Star will get a rectangle :

1. The four vertexes of it are on the outline of the oval.

2. The two sides of it parallel to coordinate axis.

3. One of its side is y=c.

Patrick Star want to know the expectations of the rectangle's perimeter.

Input

The first line contain a integer T (no morn than 10), the following is T test case, for each test case :

Each line contains contains two integer a, b (0<b<a<105). Separated by an white space.

Output

For each test case output one line denotes the expectations of the rectangle's perimeter .

You should keep exactly 6 decimal digits and ignore the remain decimal digits. 

It is guaranted that the 7-th decimal digit of answer wont be 0 or 9.

Sample Input

1 2 1

Sample Output

8.283185

题意:给你一个椭圆,求其内接矩形的周长期望

答案就是aπ+2b,注意它不是四舍五入是截断,不知道怎么积分也没关系,可以暴力然后再找规律

#include<stdio.h>
#include<math.h>
using namespace std;
#define PI acos(-1.0)
int main(void)
{
	int T;
	double a, b;
	scanf("%d", &T);
	while(T--)
	{
		scanf("%lf%lf", &a, &b);
		printf("%.6f\n", floor((a*PI+2*b)*1000000)/1000000);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Jaihk662/article/details/81515571