hdu - 4349 Xiao Ming's Hope Lucs定理推导

Xiao Ming's Hope

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2609    Accepted Submission(s): 1790

 

Problem Description

Xiao Ming likes counting numbers very much, especially he is fond of counting odd numbers. Maybe he thinks it is the best way to show he is alone without a girl friend. The day 2011.11.11 comes. Seeing classmates walking with their girl friends, he coundn't help running into his classroom, and then opened his maths book preparing to count odd numbers. He looked at his book, then he found a question "C(n,0)+C(n,1)+C(n,2)+...+C(n,n)=?". Of course, Xiao Ming knew the answer, but he didn't care about that , What he wanted to know was that how many odd numbers there were? Then he began to count odd numbers. When n is equal to 1, C(1,0)=C(1,1)=1, there are 2 odd numbers. When n is equal to 2, C(2,0)=C(2,2)=1, there are 2 odd numbers...... Suddenly, he found a girl was watching him counting odd numbers. In order to show his gifts on maths, he wrote several big numbers what n would be equal to, but he found it was impossible to finished his tasks, then he sent a piece of information to you, and wanted you a excellent programmer to help him, he really didn't want to let her down. Can you help him?

 

 

Input

Each line contains a integer n(1<=n<=108)

 

 

Output

A single line with the number of odd numbers of C(n,0),C(n,1),C(n,2)...C(n,n).

 

 

Sample Input

1

2

11

 

 

Sample Output

2

2

8

 

 

Author

HIT

 

 

Source

2012 Multi-University Training Contest 5

 

 

Recommend

zhuyuanchen520   |   We have carefully selected several similar problems for you:  4340 4348 4347 4346 4345 

 算法分析:

题意:

给n,求c(n,0),c(n,1)....c(n,n)中奇数的个数

分析:

先给一个Lucas推论
将n,m(0~n) 化为二进制数

 

a[],b[]为n,m的二进制数

 

根据定理 C(n,m)=C(a[n],b[n])*C(a[n-1],b[n-1])*...*C(a[0],b[0])

 官方题解:

Lucas定理推导,我们分析一下 C(n,m)%2,那么由lucas定理,我们可以写成二进制的形式观察,比如 n=1001101m是从0000001001101的枚举,我们知道在该定理中C(0,1)=0,因此如果n=10011010对应位置的m二进制位为1那么C(n,m) % 2==0,因此m对应n0的位置只能填0,而1的位置填0,填1都是1C(1,0)=C(1,1)=1),不影响结果为奇数,并且保证不会出n的范围,因此所有的情况即是n1位置对应m位置01的枚举,那么结果很明显就是:2^(n1的个数)

规律:

判断组合数奇偶性的一个规律:如果(n&m)==m,那么C(n,m)为奇数,否则为偶数

 代码实现:

#include<cstdio>  
#include<cstring>  
#include<cstdlib>  
#include<cctype>  
#include<cmath>  
#include<iostream>  
#include<sstream>  
#include<iterator>  
#include<algorithm>  
#include<string>  
#include<vector>  
#include<set>  
#include<map>  
#include<stack>  
#include<deque>  
#include<queue>
using namespace std;
int main()
{
	int n;
	
	while(scanf("%d",&n)!=EOF)
	{
		int sum=0;
	 while(n)
	 {
	 	if(n&1) sum++;
	 	 n=n>>1;
	 }
	 int ans=(int)pow(2.0,sum*1.0);
	 cout<<ans<<endl;
	}
    return 0;
}
 

猜你喜欢

转载自blog.csdn.net/sdz20172133/article/details/81637419
今日推荐