hdu 6342 Expression in Memories(模拟)

Kazari remembered that she had an expression s0 before.
Definition of expression is given below in Backus–Naur form.
::= |
::= “+” | “*”
::= “0” |
::= “” |
::= “0” |
::= “1” | “2” | “3” | “4” | “5” | “6” | “7” | “8” | “9”
For example, 1*1+1, 0+8+17 are valid expressions, while +1+1, +1*+1, 01+001 are not.
Though s0 has been lost in the past few years, it is still in her memories.
She remembers several corresponding characters while others are represented as question marks.
Could you help Kazari to find a possible valid expression s0 according to her memories, represented as s, by replacing each question mark in s
with a character in 0123456789+* ?

Input
The first line of the input contains an integer T denoting the number of test cases.
Each test case consists of one line with a string s (1≤|s|≤500,∑|s|≤105).
It is guaranteed that each character of s
will be in 0123456789+*? .

Output
For each test case, print a string s0
representing a possible valid expression.
If there are multiple answers, print any of them.
If it is impossible to find such an expression, print IMPOSSIBLE.

Sample Input

5
?????
0+0+0
?+*??
?0+?0
?0+0?

Sample Output

11111
0+0+0
IMPOSSIBLE
10+10
IMPOSSIBLE
#include<bits/stdc++.h>
using namespace std;

int main(){
    int t, l, i;  char s[550]; bool flag;
    scanf("%d", &t);
    while(t--){
        scanf("%s", s);
        flag = 1;
        l = strlen(s);
        for(i = 1; i < l; i++){
            if(s[i] == '?' && s[i-1] == '0' && (s[i-2] == '+' || s[i-2] == '*' || i == 1)){
                s[i] = '+';
            }
        }
        for(i = 0; i < l; i++){
            if(s[i] == '?')
                s[i] = '1';
        }
        for(i = 1; i < l; i++){
            if(s[0] == '+' || s[0] == '*' || s[l-1] == '+' || s[l-1] == '*'){
                flag = 0;
                break;
            }
            else if((s[i] == '+' || s[i] == '*') && (s[i-1] == '+' || s[i-1] == '*')){
                flag = 0;
                break;
            }
        }
        for(i = 0; i < l-1; i++){
            if(s[i] == '0' && (s[i-1] == '+' || s[i-1] == '*' || i == 0) && (s[i+1] != '+' && s[i+1] != '*')){
                flag = 0;
                break;
            }
        }
        if(flag){
            printf("%s\n", s);
        }
        else{
            printf("IMPOSSIBLE\n");
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/ling_wang/article/details/81477030
今日推荐