Mirror, Mirror on the Wall

Description

  For most fonts, the lowercase letters b and d are mirror images of each other, as are the letters p and q. Furthermore, letters i, o, v, w, and x are naturally mirror images of themselves. Although other symmetries exists for certain fonts, we consider only those specifically mentioned thus far for the remainder of this problem.

  Because of these symmetries, it is possible to encode certain words based upon how those words would appear in the mirror. For example the word boxwood would appear as boowxod, and the word ibid as bidi. Given a particular sequence of letters, you are to determine its mirror image or to note that it is invalid.

Input

  The input contains a series of letter sequences, one per line, followed by a single line with the ‘#’ character. Each letter sequence consists entirely of lowercase letters.

Output

  For each letter sequence in the input, if its mirror image is a legitimate letter sequence based upon the given symmetries, then output that mirror image. If the mirror image does not form a legitimate sequence of characters, then output the word ‘INVALID’.

Sample Input

boowxod

bidi

bed

bbb

#

Sample Output

boxwood

ibid

INVALID

ddd

解析

  题中所说的镜像变换我们不妨拿样例1 boowxod 举例子,通过观察样例输出 boxwood 发现,boxwood 是由 boowxod 从末尾的字符开始镜象变换的,d的镜像字符是b,输出b。o的镜像字符是o,输出o......一直到首字符b变换输出d。

代码

#include<stdio.h>
#include<string.h>
#define MAX 100005
int main()
{
    char str[MAX],temp[MAX];
    while(~scanf("%s",str))
    {
        int len=strlen(str);
        if(len==1&&str[0]=='#')
             break;
        int i,j,flag=1;
        for(i=len-1,j=0;i>=0;i--,j++)
        {
            if(str[i]=='b')
                temp[j]='d';
            else if(str[i]=='d')
                temp[j]='b';
            else if(str[i]=='p')
                temp[j]='q';
            else if(str[i]=='q')
                temp[j]='p';
            else if(str[i]=='i')
                temp[j]=str[i];
            else if(str[i]=='o')
                temp[j]=str[i];
            else if(str[i]=='v')
                temp[j]=str[i];
            else if(str[i]=='w')
                temp[j]=str[i];
            else if(str[i]=='x')
                temp[j]=str[i];
            else
                flag=0;
        }
        if(!flag)
            printf("INVALID\n");
        else
        {
            for(i=0;i<len;i++)
            {
                printf("%c",temp[i]);
            }
            printf("\n");
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/ZCMU_2024/article/details/81568324