Left Mouse Button(DFS)

Description

  Mine sweeper is a very popular small game in Windows operating system. The object of the game is to find mines, and mark them out. You mark them by clicking your right mouse button. Then you will place a little flag where you think the mine is. You click your left mouse button to claim a square as not being a mine. If this square is really a mine, it explodes, and you lose. Otherwise, there are two cases. In the first case, a little colored numbers, ranging from 1 to 8, will display on the corresponding square. The number tells you how many mines are adjacent to the square. For example, if you left-clicked a square, and a little 8 appeared, then you would know that this square is surrounded by 8 mines, all 8 of its adjacent squares are mines. In the second case, when you left-click a square whose all adjacent squares are not mines, then all its adjacent squares (8 of its adjacent squares) are mine-free. If some of these adjacent squares also come to the second case, then such deduce can go on. In fact, the computer will help you to finish such deduce process and left-click all mine-free squares in the process. The object of the game is to uncover all of the non-mine squares, without exploding any actual mines. Tom is very interesting in this game. Unfortunately his right mouse button is broken, so he could only use his left mouse button. In order to avoid damage his mouse, he would like to use the minimum number of left clicks to finish mine sweeper. Given the current situation of the mine sweeper, your task is to calculate the minimum number of left clicks.

                                                                                

Input

  The first line of the input contains an integer T (T <= 12), indicating the number of cases. Each case begins with a line containing an integer n (5 <= n <= 9), the size of the mine sweeper is n×n. Each of the following n lines contains n characters M ij(1 <= i,j <= n), M ij denotes the status of the square in row i and column j, where ‘@’ denotes mine, ‘0-8’ denotes the number of mines adjacent to the square, specially ‘0’ denotes there are no mines adjacent to the square. We guarantee that the situation of the mine sweeper is valid. 

Output

  For each test case, print a line containing the test case number (beginning with 1) and the minimum left mouse button clicks to finish the game.

Sample Input

1
9
001@11@10
001111110
001111110
001@22@10
0012@2110
221222011
@@11@112@
2211111@2
000000111

Sample Output

Case 1: 24

解析

 根据扫雷的规则,点在0的位置话,会将一片连在一起的0全部显示出来外加0的周围一圈。而非零的位置(不包括雷)点一次只能显示一个位置。问说最少要多少步可以点完所有没有雷的位置。

 遍历图,碰到'0'的时候用dfs搜索将一片整体的全标记起来。然后最后再计算没有标记且不是雷的位置的个数,加上前面调用dfs的次数就是答案了。

代码

#include<stdio.h>
#include<string.h>
#define MAX 10
int dir[8][2]={{0,1},{0,-1},{1,0},{-1,0},{1,-1},{1,1},{-1,-1},{-1,1}};
int vis[MAX][MAX],n;
char maze[MAX][MAX];
void DFS(int x,int y)
{
    vis[x][y]=1;
    if(maze[x][y]!='0') return ;
    int i,tempx,tempy;
    for(i=0;i<8;i++)
    {
        tempx=x+dir[i][0];
        tempy=y+dir[i][1];
        if(tempx<0||tempx>n||tempy<0||tempy>n)
            continue;
        if(!vis[tempx][tempy])
            DFS(tempx,tempy);
    }
    return ;
}
int main()
{
    int T,kase=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%s",maze[i]);
        }
        memset(vis,0,sizeof(vis));
        int ans=0,i,j;
       for(i=0;i<n;i++)
       {
         for(j=0;j<n;j++)
         {
            if(!vis[i][j]&&maze[i][j]=='0')
            {
                DFS(i,j);
                ans+=1;
            }
         }
       }
       for(i=0;i<n;i++)
       {
          for(j=0;j<n;j++)
          {
            if(!vis[i][j]&&maze[i][j]!='@')
                ans+=1;
          }
       }
      printf("Case %d: %d\n",kase,ans);
      kase+=1;
    }
    return 0;
}

 

猜你喜欢

转载自blog.csdn.net/ZCMU_2024/article/details/81589420