1017 Queueing at Bank

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10000) - the total number of customers, and K (<=100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:

7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10
Sample Output:

8.2

题目大意:客户到银行办理业务,银行只有k个窗口,且只在08:00-15:00之间营业。根据客户到达银行的时间与办理业务的时长,求客户平均等待的时长。

分析:根据顾客到达银行的时间,进行排序存储。使用优先队列存储每个窗口对下一顾客开放的时刻,这样方便从中找出最早无人的窗口。遍历顾客的过程中,找到最早开放的窗口,记下开放时刻firstEndTime,与顾客到达时间time进行比较。

参考代码:

#include<iostream>
#include<vector>
#include<algorithm>
#include<queue>

using namespace std;
struct node {
    int time,p;   //到达银行的时间,办理业务的时长
};
bool cmp(node a,node b)
{
    return a.time < b.time;
}
int main()
{
    int n, k, hour, minute, second, processing;
    int total = 0, firstEndTime, deadline = 15 * 60 * 60, cnt = 0;
    vector<struct node>customers;
    struct node tempNode;
    cin >> n >> k;

    priority_queue<int, vector<int>, greater<int> >q;
    for (int i = 1; i <= k; i++)
        q.push(8 * 60 * 60);
    //输入n位客户的信息
    for (int i = 1; i <= n; i++)
    {
        scanf_s("%d:%d:%d %d", &hour, &minute, &second, &processing);
        tempNode.time = hour * 60 * 60 + minute * 60 + second;
        tempNode.p = processing* 60;
        customers.push_back(tempNode);
    }
    //按照到达时刻的早晚进行排序
    sort(customers.begin(), customers.end(), cmp);
    //遍历顾客
    for (auto val:customers)
    {
        if (val.time<= deadline)
        {
            //寻找窗口
            firstEndTime = q.top();
            q.pop();
            //无需等待
            if (val.time >= firstEndTime)
            {
                total += 0;
                q.push(val.time + val.p);
            }
            else 
            { //需要等待
                total += abs(firstEndTime - val.time);
                q.push(firstEndTime + val.p);
            }
            cnt++;
        }
    }

    if(cnt!=0)
    printf("%.1f", total*1.0 / 60 / cnt);

    return 0;
}

猜你喜欢

转载自blog.csdn.net/ssf_cxdm/article/details/81558086