暑假集训day5 ——进制转换

进制转换

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic Discuss

Problem Description

输入一个十进制数N,将它转换成R进制数输出。

Input

输入数据包含多个测试实例,每个测试实例包含两个整数N(32位整数)和R(2<=R<=16, R != 10)。

Output

为每个测试实例输出转换后的数,每个输出占一行。如果R大于10,则对应的数字规则参考16进制(比如,10用A表示,等等)。

Sample Input

7 2
23 12
-4 3

Sample Output

111
1B
-11

#include<stdio.h>

void binary(int n, int m)
{
    int x;

    if(n == 0)
    {
        return ;
    }

    else
    {
        binary(n / m, m);

        x = n % m;

        if(x < 10)
        {
            printf("%d", x);
        }

        else
        {
            printf("%c", x + 'A' - 10);
        }
    }


}

int main(void)
{
    int n, r;

    while(~scanf("%d %d", &n, &r))
    {
        if(n == 0)
        {
            printf("%d", 0);
        }

        else if(n < 0)
        {
            printf("-");
            n = -n;
        }

        binary(n, r);

        printf("\n");
    }

    return 0;
}
 

猜你喜欢

转载自blog.csdn.net/Eider1998/article/details/81383115
今日推荐