Sliding Window(单调队列)

                                   Sliding Window

Time Limit: 12000MS   Memory Limit: 65536K
Total Submissions: 69954   Accepted: 19862
Case Time Limit: 5000MS

Description

An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is [1 3 -1 -3 5 3 6 7], and k is 3.

Window position Minimum value Maximum value
[1  3  -1] -3  5  3  6  7  -1 3
 1 [3  -1  -3] 5  3  6  7  -3 3
 1  3 [-1  -3  5] 3  6  7  -3 5
 1  3  -1 [-3  5  3] 6  7  -3 5
 1  3  -1  -3 [5  3  6] 7  3 6
 1  3  -1  -3  5 [3  6  7] 3 7

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

<span style="color:#000000">8 3
1 3 -1 -3 5 3 6 7
</span>

Sample Output

<span style="color:#000000">-1 -3 -3 -3 3 3
3 3 5 5 6 7
</span>

Source

POJ Monthly--2006.04.28, Ikki

扫描二维码关注公众号,回复: 2699101 查看本文章
#include<iostream>
#include<cstdio>
using namespace std;
const int MAXN=1000000+10;
int n,k,maxh,minh,maxt,mint;
int maxq[MAXN],minq[MAXN],num[MAXN];
int maxans[MAXN],minans[MAXN];

int main()
{
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        maxh=0,minh=0,mint=0,mint=0;
        for(int i=0;i<n;i++)
        {
            if(maxh<maxt&&maxq[maxh]<=i-k) maxh++;
            if(minh<mint&&minq[minh]<=i-k) minh++;

            scanf("%d",&num[i]);
            while(maxh<maxt&&num[maxq[maxt-1]]<num[i])
                maxt--;
            maxq[maxt++]=i;
            while(minh<mint&&num[minq[mint-1]]>num[i])
                mint--;
            minq[mint++]=i;

            maxans[i]=num[maxq[maxh]];
            minans[i]=num[minq[minh]];

        }
        for(int i=k-1;i<n;i++)  cout<<minans[i]<<' '; puts("");
        for(int i=k-1;i<n;i++)  cout<<maxans[i]<<' '; puts("");
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/sadsummerholiday/article/details/81320608