(并查集)Find them, Catch them

题目

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

  1. D [a] [b]
    where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

  2. A [a] [b]
    where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.
    Input
    The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
    Output
    For each message “A [a] [b]” in each case, your program should give the judgment based on the information got before. The answers might be one of “In the same gang.”, “In different gangs.” and “Not sure yet.”
    Sample Input
    1
    5 5
    A 1 2
    D 1 2
    A 1 2
    D 2 4
    A 1 4
    Sample Output
    Not sure yet.
    In different gangs.
    In the same gang.

分析与解答

这题就是我在prim算法里提到过的,利用数组的思想,数组可以表示两个数的关系,那我们就建一个enemy数组,enemy[a]表示a的敌人是b,每次出现一个D的时候,表明a和b是敌人,那b和enemy[a]就是同一个根,连接起来就行

#include <cstdio>
#include <cstring>
#include <algorithm>
#define maxn 130000
using namespace std;

int per[maxn], num[maxn], n, m;

int find(int x){
    if(x == per[x])
        return x;
    return per[x] = find(per[x]);
}

void join(int x, int y){
    int fx = find(x);
    int fy = find(y);
    if(fx != fy){
        per[fx] = fy;//把fy规定为fx祖宗 
    }
    return ;
}
int a,b,ch,count2=0,enemy[100100];
int main (){
    int t;
    scanf("%d",&t);
    while(t--){
        memset(enemy,0,sizeof(enemy));
        scanf("%d%d",&n,&m);
        for(int j=1;j<=n;++j){
            per[j]=j;
        }
        for(int i=0;i<m;++i){
            scanf(" %c%d%d",&ch,&a,&b);
            if (ch == 'D') {
              if (enemy[a]) join(enemy[a],b);
              if (enemy[b]) join(enemy[b],a);
              enemy[a] = b;
              enemy[b] = a;
              }
            else {
              if (find(a) == find(enemy[b])) printf("In different gangs.\n");
              else if (find(a) == find(b)) printf("In the same gang.\n");
              else printf("Not sure yet.\n");
              }
        }
    }
}

猜你喜欢

转载自blog.csdn.net/qq_40828914/article/details/81566935