简单DP(时间段类)

阅读数:501

Milking Time

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5896   Accepted: 2462

Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houriN), an ending hour (starting_houri < ending_houriN), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ RN) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: N, M, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43
题意给定一个时间间隔N在这个时间间隔内有M段段时间给出这M段时间每段的工作量和开始终止时间求N时间最大工作量每段工作后要休息R(将R算在每个时间段的结尾)
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<iostream>
#define N 0x3f3f3f3f
using namespace std;
struct ac
{
	int s,e,l;
}r[1010];
int dp[1010];
int cmp(ac x,ac y)
{
	return x.e<y.e;
}
int main()
{
	int t,n,m;
	cin>>t>>n>>m;
	for(int i=1;i<=n;i++)
	{
		cin>>r[i].s>>r[i].e>>r[i].l;
	}
	sort(r+1,r+n+1,cmp);
	int maxx=0; 
	for(int i=1;i<=n;i++)
	{
		dp[i]=r[i].l;
		for(int j=1;j<i;j++)
		{
			if(r[j].e+m<=r[i].s)//条件是 前者加上休息时间m 小于或者等于 后者的开始时间 
			{
				//dp[i] 用来存储i的值
				//dp[j]+r[i].l 表示上次dp[j]的最大值与i的最大值相加 
				//比较两者的大小 
				dp[i]=max(dp[i],dp[j]+r[i].l);
				
			}
		}
		maxx=max(maxx,dp[i]);
	}
	cout<<maxx<<endl;
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/henucm/article/details/81107038
今日推荐