Friends (ZOJ - 3710)

Problem

Alice lives in the country where people like to make friends. The friendship is bidirectional and if any two person have no less than k friends in common, they will become friends in several days. Currently, there are totally n people in the country, and m friendship among them. Assume that any new friendship is made only when they have sufficient friends in common mentioned above, you are to tell how many new friendship are made after a sufficiently long time.


Input

There are multiple test cases.

The first lien of the input contains an integer T (about 100) indicating the number of test cases. Then T cases follow. For each case, the first line contains three integers n, m, k (1 ≤ n ≤ 100, 0 ≤ m ≤ n×(n-1)/2, 0 ≤ k ≤ n, there will be no duplicated friendship) followed by m lines showing the current friendship. The ithfriendship contains two integers ui, vi (0 ≤ ui, vi < n, ui ≠ vi) indicating there is friendship between person ui and vi.

Note: The edges in test data are generated randomly.


Output

For each case, print one line containing the answer.


Sample Input

3
4 4 2
0 1
0 2
1 3
2 3
5 5 2
0 1
1 2
2 3
3 4
4 0
5 6 2
0 1
1 2
2 3
3 4
4 0
2 0

Sample Output

2
0
4

题解:暴力遍历所有朋友直到不再出现新的朋友关系就可以了。

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
using namespace std;
typedef long long ll;
int vis[110][110];       //用来判断是否是朋友关系
int main()
{
    int n,i,j,m,t,k,ans,x,y,l;
    while(scanf("%d",&t) != EOF)
    {
        while(t--)
        {
            scanf("%d%d%d",&n,&m,&k);
            memset(vis,0,sizeof(vis));
            for(i=0; i<m; i++)
            {
                scanf("%d%d",&x,&y);
                vis[x][y] = 1;
                vis[y][x] = 1;
            }
            ans = 0;
            m = 0;
            while(1)
            {
                for(i=0; i<n; i++)
                {
                    for(j=0; j<n; j++)
                    {
                        if(i==j||vis[i][j]) continue;   // 如果是自己或者已经是朋友关系就不用判断了
                        x = 0;
                        for(l=0; l<n; l++)
                        {
                            if(vis[i][l]&&vis[j][l])
                                x++;
                        }
                        if(x>=k)
                        {
                            ans++;
                            vis[i][j] = vis[j][i] = 1;
                        }
                    }
                }
                if(m==ans) break;   // 如果和上次循环的结果一样,就说明不会再增加新的朋友关系了,跳出循环就可以了
                m = ans;
            }
            printf("%d\n",ans);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Mercury_Lc/article/details/81460326
ZOJ