每日一题Day17

基于链式存储结构的图书信息表的最佳位置图书的查找

描述

定义一个包含图书信息(书号、书名、价格)的链表,读入相应的图书数据来完成图书信息表的创建,然后根据指定的最佳位置的序号,查找该位置上的图书,输出相应图书的信息。

输入

总计n+m+2行。首先输入n+1行,其中,第一行是图书数目n,后n行是n本图书的信息(书号、书名、价格),每本图书信息占一行,书号、书名、价格用空格分隔,价格之后没有空格。其中书号和书名为字符串类型,价格为浮点数类型。然后输入m+1行,其中,第一行是一个整数m,代表查找m次,后m行每行内容为一个整数,代表待查找的图书的位置序号。

输出

输出m行

若查找成功:

输出内容为第i次查询的指定位置上的一本图书的信息(书号、书名、价格),书号、书名、价格用空格分隔,其中价格输出保留两位小数。

若查找失败:

只输出以下提示:抱歉,最佳位置上的图书不存在!

样例输入1 

8
9787302257646 Data-Structure 35.00
9787302164340 Operating-System 50.00
9787302219972 Software-Engineer 32.00
9787302203513 Database-Principles 36.00
9787810827430 Discrete-Mathematics 36.00
9787302257800 Data-Structure 62.00
9787811234923 Compiler-Principles 62.00
9787822234110 The-C-Programming-Language 38.00
2
2
0

样例输出1

9787302164340 Operating-System 50.00
Sorry,the book on the best position doesn't exist!

解答:尾插法建立链表,判断输出位置是否合法,若合法则输出相应的图书信息。

#include<stdio.h>
#include<stdlib.h>

typedef struct node
{
	long long int num;
	char name[50];
	double price;
	struct node *next;
} Book,*BookList;

int main()
{
	int n;
	scanf("%d",&n);
	BookList L;
	Book *p,*rear;
	L = (Book *)malloc(sizeof(Book));
	L->num=n;
	L->next=NULL;
	rear = L;
	while(n--)
	{
		p=(Book *)malloc(sizeof(Book));
		scanf("%lld %s %lf",&p->num,p->name,&p->price);
		rear->next = p;
		rear = p;
	}
	rear->next = NULL;
	int m,index;
	scanf("%d",&m);
	while(m--)
	{
		scanf("%d",&index);
		if(index>=1&&index<=L->num)
		{
			p=L;
			while(index--)
			{
				p=p->next;
			}
			printf("%lld %s %.2f\n",p->num,p->name,p->price);
		}
		else
		{
			printf("Sorry,the book on the best position doesn't exist!\n");
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ZLambert/article/details/81542375