HDOJ 1787 GCD Again (欧拉函数)求单个欧拉函数模板

GCD Again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2713    Accepted Submission(s): 1141


 

Problem Description

Do you have spent some time to think and try to solve those unsolved problem after one ACM contest?
No? Oh, you must do this when you want to become a "Big Cattle".
Now you will find that this problem is so familiar:
The greatest common divisor GCD (a, b) of two positive integers a and b, sometimes written (a, b), is the largest divisor common to a and b. For example, (1, 2) =1, (12, 18) =6. (a, b) can be easily found by the Euclidean algorithm. Now I am considering a little more difficult problem:
Given an integer N, please count the number of the integers M (0<M<N) which satisfies (N,M)>1.
This is a simple version of problem “GCD” which you have done in a contest recently,so I name this problem “GCD Again”.If you cannot solve it still,please take a good think about your method of study.
Good Luck!

Input

Input contains multiple test cases. Each test case contains an integers N (1<N<100000000). A test case containing 0 terminates the input and this test case is not to be processed.

Output

For each integers N you should output the number of integers M in one line, and with one line of output for each line in input.

Sample Input

 

2 4 0

Sample Output

 

0 1

打标模板:https://blog.csdn.net/SunPeishuai/article/details/81502440

题意:求小于n的公约数(N,M)>1的个数

思路:用n-欧拉值,注意小于n,再减1

#include<bits/stdc++.h>
using namespace std;
int euler(int n)//单个数的欧拉函数判断模板
{
    int ans=n;
    for(int i=2;i*i<=n;i++)
    {
        if(n%i==0)
        {
            ans=ans/i*(i-1);//等价于ans=ans-ans/i
            while(n%i==0)
                n=n/i;
        }
    }
    if(n>1) ans=ans/n*(n-1);
    return ans;
}
int main()
{
      int k;
    while(~scanf("%d",&k)&&k)
   {

       printf("%d\n",k-1-euler(k));
   }
   return 0;
}

猜你喜欢

转载自blog.csdn.net/SunPeishuai/article/details/81501951