2.类和对象习题总结

编程题1:

描述

下面程序输出的结果是:

0

5

请填空:

#include <iostream>
using namespace std;
class A {
public:
    int val;
// 在此处补充你的代码
};
main()  {
    A a;
    cout << a.val << endl;
    a.GetObj() = 5;
    cout << a.val << endl;
}

输入无输出0
5样例输入

样例输出

0
5

提示所缺代码具有如下形式:

    A(_________________ ){ val = n; }
    ________________ GetObj() {
        return _________________;
    }
#include <iostream>
using namespace std;
class A {
public:
	int val;
	A(int n = 0){ val = n;}  //构造函数,使val=0
	A& GetObj() {
		return *this;    //*this指针在主函数调用此函数时指向对象a
	}
};
int main()  {
	A a;
	cout << a.val << endl;
	a.GetObj() = 5;
	cout << a.val << endl;
	system("pause");
}

编程题2:

描述

下面程序的输出是:

10

请补足Sample类的成员函数。不能增加成员变量。

#include <iostream>
using namespace std;
class Sample{
public:
    int v;
    Sample(int n):v(n) { }
// 在此处补充你的代码
};
int main() {
    Sample a(5);
    Sample b = a;
    cout << b.v;
    return 0;
}

输入无输出10样例输入

样例输出

10

程序:

#include <iostream>
using namespace std;
class Sample{
public:
	int v;
	Sample(int n) :v(n) { }
	Sample(Sample & a) {
		v = 10;
	}                           //定义拷贝构造函数,不然主函数cout.b.v将输出5
};
int main() {
	Sample a(5);
	Sample b = a;
	cout << b.v;
	system("pause");
	return 0;
}

编程题3:

描述

下面程序的输出结果是:

5,5

5,5

请填空:

#include <iostream>
using namespace std;
class Base {
public:
    int k;
    Base(int n):k(n) { }
};
class Big  {
public:
    int v; Base b;
// 在此处补充你的代码
};
int main()  {
    Big a1(5);    Big a2 = a1;
    cout << a1.v << "," << a1.b.k << endl;
    cout << a2.v << "," << a2.b.k << endl;
    return 0;
}

输入无输出5,5
5,5样例输入

样例输出

5,5
5,5

提示所缺代码具有如下形式:

    Big ________________{ }
    Big ________________{ }

程序:

#include <iostream>
using namespace std;
class Base {
public:
	int k;
	Base(int n) :k(n) { }
};
class Big  {
public:
	int v; Base b;
	Big(int n) :v(n),b(n){};   //参考封闭类构造函数
};
int main()  {
	Big a1(5);    Big a2 = a1;
	cout << a1.v << "," << a1.b.k << endl;
	cout << a2.v << "," << a2.b.k << endl;
	system("pause");
	return 0;
}

编程题4:

描述

魔兽世界的西面是红魔军的司令部,东面是蓝魔军的司令部。两个司令部之间是依次排列的若干城市。 
红司令部,City 1,City 2,……,City n,蓝司令部

两军的司令部都会制造武士。武士一共有 dragon 、ninja、iceman、lion、wolf 五种。每种武士都有编号、生命值、攻击力这三种属性。 

双方的武士编号都是从1开始计算。红方制造出来的第n个武士,编号就是n。同样,蓝方制造出来的第n个武士,编号也是n。 

武士在刚降生的时候有一个生命值。 

在每个整点,双方的司令部中各有一个武士降生。 

红方司令部按照iceman、lion、wolf、ninja、dragon的顺序循环制造武士。 

蓝方司令部按照lion、dragon、ninja、iceman、wolf的顺序循环制造武士。 

制造武士需要生命元。 

制造一个初始生命值为m的武士,司令部中的生命元就要减少m个。 

如果司令部中的生命元不足以制造某个按顺序应该制造的武士,那么司令部就试图制造下一个。如果所有武士都不能制造了,则司令部停止制造武士。

给定一个时间,和双方司令部的初始生命元数目,要求你将从0点0分开始到双方司令部停止制造武士为止的所有事件按顺序输出。
一共有两种事件,其对应的输出样例如下: 

1) 武士降生 
输出样例: 004 blue lion 5 born with strength 5,2 lion in red headquarter
表示在4点整,编号为5的蓝魔lion武士降生,它降生时生命值为5,降生后蓝魔司令部里共有2个lion武士。(为简单起见,不考虑单词的复数形式)注意,每制造出一个新的武士,都要输出此时司令部里共有多少个该种武士。

2) 司令部停止制造武士
输出样例: 010 red headquarter stops making warriors
表示在10点整,红方司令部停止制造武士

输出事件时: 

首先按时间顺序输出; 

同一时间发生的事件,先输出红司令部的,再输出蓝司令部的。

输入

第一行是一个整数,代表测试数据组数。

每组测试数据共两行。 

第一行:一个整数M。其含义为, 每个司令部一开始都有M个生命元( 1 <= M <= 10000)。

第二行:五个整数,依次是 dragon 、ninja、iceman、lion、wolf 的初始生命值。它们都大于0小于等于10000。

输出

对每组测试数据,要求输出从0时0分开始,到双方司令部都停止制造武士为止的所有事件。
对每组测试数据,首先输出"Case:n" n是测试数据的编号,从1开始 。
接下来按恰当的顺序和格式输出所有事件。每个事件都以事件发生的时间开头,时间以小时为单位,有三位。

样例输入

1
20
3 4 5 6 7

样例输出

Case:1
000 red iceman 1 born with strength 5,1 iceman in red headquarter
000 blue lion 1 born with strength 6,1 lion in blue headquarter
001 red lion 2 born with strength 6,1 lion in red headquarter
001 blue dragon 2 born with strength 3,1 dragon in blue headquarter
002 red wolf 3 born with strength 7,1 wolf in red headquarter
002 blue ninja 3 born with strength 4,1 ninja in blue headquarter
003 red headquarter stops making warriors
003 blue iceman 4 born with strength 5,1 iceman in blue headquarter
004 blue headquarter stops making warriors

程序:

注:这是郭炜老师的标准答案,我只是加了点注释便于自己理解。


#include <iostream>
#include <cstdio>
#include <string>
using namespace std;
const int  WARRIOR_NUM = 5;
/*
string Warrior::names[WARRIOR_NUM] = { "dragon","ninja","iceman","lion","wolf" };
红方司令部按照 iceman、lion、wolf、ninja、dragon 的顺序制造武士。
蓝方司令部按照 lion、dragon、ninja、iceman、wolf 的顺序制造武士。
*/

class Headquarter;
class Warrior
{
private:
	Headquarter * pHeadquarter;
	int kindNo; //武士的种类编号 0 dragon 1 ninja 2 iceman 3 lion 4 wolf
	int no;
public:
	static string names[WARRIOR_NUM];
	static int initialLifeValue[WARRIOR_NUM];
	Warrior(Headquarter * p, int no_, int kindNo_);
	void PrintResult(int nTime);
};

class Headquarter
{
private:
	int totalLifeValue;
	bool stopped;
	int totalWarriorNum;
	int color;
	int curMakingSeqIdx; //当前要制造的武士是制造序列中的第几个
	int warriorNum[WARRIOR_NUM]; //存放每种武士的数量
	Warrior * pWarriors[1000];
public:
	friend class Warrior;
	static int makingSeq[2][WARRIOR_NUM]; //武士的制作顺序序列
	void Init(int color_, int lv);
	~Headquarter();
	int Produce(int nTime);
	string GetColor();

};


Warrior::Warrior(Headquarter * p, int no_, int kindNo_) {
	no = no_;
	kindNo = kindNo_;
	pHeadquarter = p;
}

void Warrior::PrintResult(int nTime)
{
	string color = pHeadquarter->GetColor();
	printf("%03d %s %s %d born with strength %d,%d %s in %s headquarter\n",
		nTime, color.c_str(), names[kindNo].c_str(), no, initialLifeValue[kindNo],
		pHeadquarter->warriorNum[kindNo], names[kindNo].c_str(), color.c_str());
}

void Headquarter::Init(int color_, int lv)
{
	color = color_;               //color = 0
	totalLifeValue = lv;          //总生命元是m
	totalWarriorNum = 0;          //初始未产生士兵
	stopped = false;              //初始未停止
	curMakingSeqIdx = 0;          //初始化制造第0个
	for (int i = 0; i < WARRIOR_NUM; i++)
		warriorNum[i] = 0;             //各种武士的初始数量为0
}

Headquarter::~Headquarter() {
	for (int i = 0; i < totalWarriorNum; i++)
		delete pWarriors[i];
}

int Headquarter::Produce(int nTime)
{

	if (stopped)               
		return 0;
	int searchingTimes = 0;
	while (Warrior::initialLifeValue[makingSeq[color][curMakingSeqIdx]] > totalLifeValue &&
		searchingTimes < WARRIOR_NUM) {
		curMakingSeqIdx = (curMakingSeqIdx + 1) % WARRIOR_NUM;
		searchingTimes++;                            //while循环判断生命值是否够制造下去
	}
	int kindNo = makingSeq[color][curMakingSeqIdx];
	if (Warrior::initialLifeValue[kindNo] > totalLifeValue) {
		stopped = true;                              //如果不足以制造则停止,然后输出字串
		if (color == 0)
			printf("%03d red headquarter stops making warriors\n", nTime);
		else
			printf("%03d blue headquarter stops making warriors\n", nTime);
		return 0;
	}
	//制作士兵:
	totalLifeValue -= Warrior::initialLifeValue[kindNo];
	curMakingSeqIdx = (curMakingSeqIdx + 1) % WARRIOR_NUM;
	pWarriors[totalWarriorNum] = new Warrior(this, totalWarriorNum + 1, kindNo);
	warriorNum[kindNo]++;
	pWarriors[totalWarriorNum]->PrintResult(nTime);
	totalWarriorNum++;
	return 1;
}

string Headquarter::GetColor()
{
	if (color == 0)
		return "red";
	else
		return "blue";
}

string Warrior::names[WARRIOR_NUM] = { "dragon", "ninja", "iceman", "lion", "wolf" };
int Warrior::initialLifeValue[WARRIOR_NUM];
int Headquarter::makingSeq[2][WARRIOR_NUM] = { { 2, 3, 4, 1, 0 }, { 3, 0, 1, 2, 4 } }; //两个司令部武士的制作顺序序列

int main()
{
	int t;
	int m;
	Headquarter RedHead, BlueHead;   //定义两个司令部对象
	cin >> t;
	int nCaseNo = 1;
	while (t--) {                    //循环表示几个例子
		printf("Case:%d\n", nCaseNo++);      //输出case:...
		scanf_s("%d", &m,3);                     //输入司令部生命元
		for (int i = 0; i < WARRIOR_NUM; i++)
			scanf_s("%d", &Warrior::initialLifeValue[i],6);  //输入初始生命值
		RedHead.Init(0, m);                     //红方初始化
		BlueHead.Init(1, m);                    //蓝方初始化
		int nTime = 0;                          //初始时间为00
		while (true) {                          //循环正常条件一直下去
			int tmp1 = RedHead.Produce(nTime);  //先判断是否可以制造,再制造输出语句
			int tmp2 = BlueHead.Produce(nTime); //同上
			if (tmp1 == 0 && tmp2 == 0)         //都不能制造则退出循环
				break;
			nTime++;                            //时间+1
		}
	}
	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/popoffpopoff/article/details/81045188
今日推荐