(HDU2005 C++) 第几天?

第几天?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 183873 Accepted Submission(s): 65227

Problem Description

给定一个日期,输出这个日期是该年的第几天。

Input

输入数据有多组,每组占一行,数据格式为YYYY/MM/DD组成,具体参见sample input ,另外,可以向你确保所有的输入数据是合法的。

Output

对于每组输入数据,输出一行,表示该日期是该年的第几天。

Sample Input

1985/1/20
2006/3/12

Sample Output

20
71

#include<iostream>
using namespace std;
int main()
{
    int year, month, day, days;
    char a, b;
    while (cin >> year >> a >> month >> b >> day)
    {
        int m[12] = { 31,28,31,30,31,30,31,31,30,31,30,31 };
        days = 0;
        if ((year % 100 != 0 && year % 4 == 0) || (year % 400 == 0))
            m[1]++;
        for (int i = 0; i < month-1; i++)
            days += m[i];
        days += day;
        cout << days << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_38780240/article/details/81331168