LITTLE SHOP OF FLOWERS(POJ 1157)

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 22648   Accepted: 10463


You want to arrange the window of your flower shop in a most pleasant way. You have F bunches of flowers, each being of a different kind, and at least as many vases ordered in a row. The vases are glued onto the shelf and are numbered consecutively 1 through V, where V is the number of vases, from left to right so that the vase 1 is the leftmost, and the vase V is the rightmost vase. The bunches are moveable and are uniquely identified by integers between 1 and F. These id-numbers have a significance: They determine the required order of appearance of the flower bunches in the row of vases so that the bunch i must be in a vase to the left of the vase containing bunch j whenever i < j. Suppose, for example, you have bunch of azaleas (id-number=1), a bunch of begonias (id-number=2) and a bunch of carnations (id-number=3). Now, all the bunches must be put into the vases keeping their id-numbers in order. The bunch of azaleas must be in a vase to the left of begonias, and the bunch of begonias must be in a vase to the left of carnations. If there are more vases than bunches of flowers then the excess will be left empty. A vase can hold only one bunch of flowers. 

 

V A S E S

1

2

3

4

5

Bunches

1 (azaleas)

7 23 -5 -24 16

2 (begonias)

5 21 -4 10 23

3 (carnations)

-21

5 -4 -20 20


Each vase has a distinct characteristic (just like flowers do). Hence, putting a bunch of flowers in a vase results in a certain aesthetic value, expressed by an integer. The aesthetic values are presented in a table as shown below. Leaving a vase empty has an aesthetic value of 0. 


Input
According to the table, azaleas, for example, would look great in vase 2, but they would look awful in vase 4. 

To achieve the most pleasant effect you have to maximize the sum of aesthetic values for the arrangement while keeping the required ordering of the flowers. If more than one arrangement has the maximal sum value, any one of them will be acceptable. You have to produce exactly one arrangement. 

  • The first line contains two numbers: FV.
  • The following F lines: Each of these lines contains V integers, so that Aij is given as the jth number on the (i+1)st line of the input file.
  • 1 <= F <= 100 where F is the number of the bunches of flowers. The bunches are numbered 1 through F. 
  • F <= V <= 100 where V is the number of vases. 
  • -50 <= Aij <= 50 where Aij is the aesthetic value obtained by putting the flower bunch i into the vase j.

Output

The first line will contain the sum of aesthetic values for your arrangement.

Sample Input

3 5
7 23 -5 -24 16
5 21 -4 10 23
-21 5 -4 -20 20

Sample Output

53

Source

IOI 1999

设S(i,k)表示第i束花摆在第k个花瓶中时(这里k>=i),前i束花能够获得的最大美学值和。这样,原问题的最优值可以通过计算max(S(F,k)),其中F<=k<=V;
递推方程 :

S(i,k)=max(S(i,k),S(i-1,j)+a(i,k)),j<=i-1<=k-1&&i>1;
S(1,k)=a(1,k);

#include<bits/stdc++.h>
using namespace std;
int a[105][105];
int s[105][105];
int main()
{
    int F,V;
    while(scanf("%d%d",&F,&V)==2)
    {
        for(int i=1;i<=F;i++)
            for(int j=1;j<=V;j++)
            scanf("%d",&a[i][j]);
        for(int i=1;i<=V;i++) s[1][i]=a[1][i];
        for(int i=2;i<=F;i++)
        for(int k=i;k<=V;k++)
        {
            s[i][k]=-1000000000;
            for(int j=i-1;j<k;j++)
                s[i][k]=max(s[i-1][j]+a[i][k],s[i][k]);
        }
        int ans=-1000000000;
        for(int i=F;i<=V;i++)
            ans=max(ans,s[F][i]);
        printf("%d\n",ans);
    }
}

猜你喜欢

转载自blog.csdn.net/qq_41061455/article/details/81301580