[HNOI2002]营业额统计(splay)

Description

营业额统计 Tiger最近被公司升任为营业部经理,他上任后接受公司交给的第一项任务便是统计并分析公司成立以来的营业情况。 Tiger拿出了公司的账本,账本上记录了公司成立以来每天的营业额。分析营业情况是一项相当复杂的工作。由于节假日,大减价或者是其他情况的时候,营业额会出现一定的波动,当然一定的波动是能够接受的,但是在某些时候营业额突变得很高或是很低,这就证明公司此时的经营状况出现了问题。经济管理学上定义了一种最小波动值来衡量这种情况: 该天的最小波动值 当最小波动值越大时,就说明营业情况越不稳定。 而分析整个公司的从成立到现在营业情况是否稳定,只需要把每一天的最小波动值加起来就可以了。你的任务就是编写一个程序帮助Tiger来计算这一个值。 第一天的最小波动值为第一天的营业额。  输入输出要求

Input

第一行为正整数 ,表示该公司从成立一直到现在的天数,接下来的n行每行有一个整数(有可能有负数) ,表示第i

天公司的营业额。

天数n<=32767,

每天的营业额ai <= 1,000,000。

最后结果T<=2^31

Output

输出文件仅有一个正整数,即Sigma(每天最小的波动值) 。结果小于2^31 。

Sample Input

6
5
1
2
5
4
6

Sample Output

12

HINT

结果说明:5+|1-5|+|2-1|+|5-5|+|4-5|+|6-5|=5+4+1+0+1+1=12

splay基本题

熟悉一遍过程。

代码:

#include <bits/stdc++.h>
using namespace std;
#define ll long long
const int maxn =1e5+10;
const int INF=0x3f3f3f3f;
int pre[maxn],key[maxn],ch[maxn][2],root,tot1;
int n;
void Newnode(int &r,int fa,int k)
{
    r=++tot1;
    pre[r]=fa;
    key[r]=k;
    ch[r][0]=ch[r][1]=0;
}
void Rotate(int x,int k)
{
    int y=pre[x];
    ch[y][!k]=ch[x][k];
    pre[ch[x][k]]=y;
    if(pre[y])ch[pre[y]][ch[pre[y]][1]==y]=x;
    pre[x]=pre[y];
    ch[x][k]=y;
    pre[y]=x;
}
void Splay(int r,int goal)
{
    while(pre[r]!=goal)
    {
        if(pre[pre[r]]==goal)
        {
            Rotate(r,ch[pre[r]][0]==r);
        }
        else
        {
            int y=pre[r];
            int kind=ch[pre[y]][0]==y;

            if(ch[y][kind]==r)
            {
                Rotate(r,!kind);
                Rotate(r,kind);
            }
            else
            {
                Rotate(y,kind);
                Rotate(r,kind);
            }
        }
    }
    if(goal==0)root=r;
}
int Insert(int k)
{
    int r=root;
    while(ch[r][key[r]<k])
    {
        if(key[r]==k)
        {
            Splay(r,0);
            return 0;
        }
        r=ch[r][key[r]<k];
    }
    Newnode(ch[r][k>key[r]],r,k);
    Splay(ch[r][k>key[r]],0);
    return 1;
}
int get_pre(int x)
{
    int tmp=ch[x][0];
    if(tmp==0)return INF;
    while(ch[tmp][1])tmp=ch[tmp][1];
    return key[x]-key[tmp];
}
int get_next(int x)
{
    int tmp=ch[x][1];
    if(tmp==0)return INF;
    while(ch[tmp][0])tmp=ch[tmp][0];
    return key[tmp]-key[x];
}

int main()
{
    while(~scanf("%d",&n))
    {
        root=tot1=0;
        int ans=0;
        for(int i=1;i<=n;i++)
        {
            int num;
            scanf("%d",&num);
            if(i==1)
            {
                ans+=num;
                Newnode(root,0,num);
                continue;
            }
            if(Insert(num)==0)continue;
            int a=get_next(root);
            int b=get_pre(root);
            ans+=min(a,b);
        }
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/a1046765624/article/details/81320613