H - The Unique MST(次小生成树)

Given a connected undirected graph, tell if its minimum spanning tree is unique.

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties:
1. V' = V.
2. T is connected and acyclic.

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'.

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2

3 3

1 2 1

2 3 2

3 1 3

4 4

1 2 2

2 3 2

3 4 2

4 1 2

Sample Output

3

Not Unique!

  • 题意概括  :

判断最小生成树是不是唯一的,如果是输出最短路径,不是则输出Not Unique!。

  • 解题思路  :

首先,进行一次最小生成树的运算找出最小生成树的值为ans,然后一一枚举不在生成树上的边,然后算出ans加上在树中的边与不在树中的边的差值差值为Min,判断Min是否与ans相等,如果相等则最小生成树不唯一,否则输出最小生成树。

#include<stdio.h>
#include<string.h>
#include<algorithm>

using namespace std;

const int inf = 0x3f3f3f3f;
int vis[110];
int lowc[110];
int pre[110];
int Max[110][110];
int used[110][110];
int cost[110][110];


int prim(int cost[][110],int n)
{
	int ans = 0,i,j,k;
	memset(vis,false,sizeof(vis));
	memset(Max,0,sizeof(Max));
	memset(used,false,sizeof(used));
	vis[0] = true;
	pre[0] = -1;
	for(i = 1;i<n;i ++)
	{
		lowc[i] = cost[0][i];
		pre[i] = 0;
	}
	lowc[0] = 0;
	for(i = 1;i<n;i ++)
	{
		int minn = inf;
		int p = -1;
		for(j = 0;j<n;j ++)
		{
			if(!vis[j]&&minn>lowc[j])
			{
				minn=lowc[j];
				p = j;
			}
		}
		if(minn == inf)
		return -1;
		ans += minn;
		vis[p] = true;
		used[p][pre[p]] = used[pre[p]][p] = true;
		for(j = 0;j<n;j ++)
		{
			if(vis[j])
			Max[j][p] = Max[p][j] = max(Max[j][pre[p]],lowc[p]);
			if(!vis[j]&&lowc[j] > cost[p][j])
			{
				lowc[j] = cost[p][j];
				pre[j] = p;
			}
		}
	}
	return ans;
}
int ans;
int smst(int cost[][110],int n)
{
	int Min = inf,i,j;
	for(i = 0;i<n;i ++)
	{
		for(j = i+1;j<n;j ++)
		{
			if(cost[i][j] != inf&&!used[i][j])
			{
				Min = min(Min,ans + cost[i][j] - Max[i][j]);
			}
		}
	}
	if(Min == inf)
	return -1;
	return Min;
}
int main()
{
	int T,u,v,w;
	int n,m,i,j,k;
	scanf("%d",&T);
	while(T --)
	{
		scanf("%d %d",&n,&m);
		for(i = 0;i<n;i ++)
		{
			for(j = 0;j<n;j ++)
			{
				if(i == j)
				cost[i][j] = 0;
				else
				cost[i][j] = inf;
			}
		}
		while(m --)
		{
			scanf("%d %d %d",&u,&v,&w);
			u--;
			v--;
			cost[u][v] = cost[v][u] = w;
		}
		ans = prim(cost,n);
		if(ans == -1)
		{
			printf("Not Unique!\n");
			continue;
		}
		if(ans == smst(cost,n))
		printf("Not Unique!\n");
		else
		printf("%d\n",ans);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/y1356998843/article/details/81333228