集训笔记---队列应用(UVAOJ NO.1594 Throwing cards away I )

Given is an ordered deck of n cards numbered 1 to n with card 1 at the top and card n at the bottom. The following operation is performed as long as there are at least two cards in the deck: Throw away the top card and move the card that is now on the top of the deck to the bottom of the deck. Your task is to find the sequence of discarded cards and the last, remaining card.

Input :Each line of input (except the last) contains a number n ≤ 50. The last line contains ‘0’ and this line should not be processed.

Output: For each number from the input produce two lines of output. The first line presents the sequence of discarded cards, the second line reports the last remaining card. No line will have leading or trailing spaces. See the sample for the expected format.

Sample Input :

7 19 10 6 0

Sample Output:

Discarded cards: 1, 3, 5, 7, 4, 2

Remaining card: 6

Discarded cards: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19, 4, 8, 12, 16, 2, 10, 18, 14

Remaining card: 6 Discarded cards: 1, 3, 5, 7, 9, 2, 6, 10, 8

Remaining card: 4

Discarded cards: 1, 3, 5, 2, 6

Remaining card: 4

一个简单的队列用法的入门题目,使用优先队列的特性,模拟整个洗牌的过程,很容易得出结果,但是要注意输出的格式,不然会PE。下面是AC代码

#include<cstdio>
#include<queue>
#include<algorithm>
using namespace std;
int main(void)
{
    int n;
    while(scanf("%d", &n))
    {
        queue<int> s;//申请队列用于存储牌 
        if(n == 0)
        {
            break;
        }
        for(int i = 1; i <= n; i++)
        {
            s.push(i);
        }
        printf("Discarded cards:");
        while(s.size() >= 2)
        {
            if(s.size() > 2)
            {
                printf(" %d,", s.front());
            }
            else
            {
                printf(" %d", s.front());
            }
            s.pop();
            int k = s.front();
            s.push(k);
            s.pop();
        }
        printf("\n");
        printf("Remaining card:");
        printf(" %d", s.front());
        printf("\n");
    }
    return 0;
}
 

猜你喜欢

转载自blog.csdn.net/zzuli_xiaomingke/article/details/81389735