Web Navigation(stl-栈)

Standard web browsers contain features to move backward and forward among the pages recently visited. One way to implement these features is to use two stacks to keep track of the pages that can be reached by moving backward and forward. In this problem, you are asked to implement this.
The following commands need to be supported:
BACK: Push the current page on the top of the forward stack. Pop the page from the top of the backward stack, making it the new current page. If the backward stack is empty, the command is ignored.
FORWARD: Push the current page on the top of the backward stack. Pop the page from the top of the forward stack, making it the new current page. If the forward stack is empty, the command is ignored.
VISIT : Push the current page on the top of the backward stack, and make the URL specified the new current page. The forward stack is emptied.
QUIT: Quit the browser.
Assume that the browser initially loads the web page at the URL http://www.acm.org/
Input
Input is a sequence of commands. The command keywords BACK, FORWARD, VISIT, and QUIT are all in uppercase. URLs have no whitespace and have at most 70 characters. You may assume that no problem instance requires more than 100 elements in each stack at any time. The end of input is indicated by the QUIT command.
Output
For each command other than QUIT, print the URL of the current page after the command is executed if the command is not ignored. Otherwise, print "Ignored". The output for each command should be printed on its own line. No output is produced for the QUIT command.
Sample Input
VISIT http://acm.ashland.edu/
VISIT http://acm.baylor.edu/acmicpc/
BACK
BACK
BACK
FORWARD
VISIT http://www.ibm.com/
BACK
BACK
FORWARD
FORWARD
FORWARD
QUIT
Sample Output
http://acm.ashland.edu/
http://acm.baylor.edu/acmicpc/
http://acm.ashland.edu/
http://www.acm.org/
Ignored
http://acm.ashland.edu/
http://www.ibm.com/
http://acm.ashland.edu/
http://www.acm.org/
http://acm.ashland.edu/
http://www.ibm.com/
Ignored
#include<iostream>
#include<cstdio>
#include<stack>
using namespace std;

const string oo="Ignored\n";

stack <string> q,h;

int main(){
    int i,l;
    string a,b,c;
    c="http://www.acm.org/";

    
    while (cin>>a){
        switch (a[0]){
            case 'V':{
                cin>>b;
                h.push(c);                                  //把当前页面推入向后堆栈
                c=b;
                while (!q.empty()) q.pop();        //访问一个新页面时,清空向前堆栈
                cout<<c<<endl;
                break;
            }
            case 'B':{
                if (!h.empty()){             //若向后堆栈非空,则把当前页面推入向前堆栈,弹出向后堆栈中的栈顶元素为当前页面
                    q.push(c);                      
                    c=h.top();
                    h.pop();
                    cout<<c<<endl;
                }
                else cout<<oo;
                break;
            }
            case 'F':{
                if (!q.empty()){             //若向前堆栈非空,则把当前页面推入向后堆栈,弹出向前堆栈中的栈顶元素为当前页面
                    h.push(c);
                    c=q.top();
                    q.pop();
                    cout<<c<<endl;
                }
                else cout<<oo;
                break;
            }
            case 'Q':{
                return 0;
                break;
            }
        }            
    }
    
    return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_41703679/article/details/79268410