Second My Problem First(单调队列)

Second My Problem First

 Give you three integers n, A and B.
Then we define S i = A i mod B and T i = Min{ S k | i-A <= k <= i, k >= 1}
Your task is to calculate the product of T i (1 <= i <= n) mod B. 

Input
Each line will contain three integers n(1 <= n <= 10 7),A and B(1 <= A, B <= 2 31-1).
Process to end of file.
Output
For each case, output the answer in a single line.
Sample Input

1 2 3
2 3 4
3 4 5
4 5 6
5 6 7

Sample Output

2
3
4
5
6

题意:

T i = Min{ S k | i-A <= k <= i, k >= 1} ,Ti是i-A到i这个范围内S的最小值,求(T1*T2*T3…….Tn)%Bd的值。

思路:

单调队列可以在o(n)的复杂度内求出区间内的最小值,用单调队列记录区间的最小值,求出答案。

code:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
typedef long long ll;
const int maxn = 1e7+10;
int s[maxn];
int que[maxn];
int main(){
    int n,a,b;
    while(~scanf("%d%d%d",&n,&a,&b)){
        int head = 0,tail = 0;
        ll tmp = 1,ans = 1;
        for(int i = 1; i <= n; i++){
            tmp = tmp * a % b;
            s[i] = tmp;
            while(head < tail && s[que[tail-1]] >= s[i]) tail--;
            que[tail++] = i;
            while(i - a > que[head]) head++;
            ans = ans * s[que[head]] %b;
        }
        printf("%lld\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/codeswarrior/article/details/81301637