UVA - 12096 The SetStack Computer(集合的交并集)

Wikipedia: “Set theory is a
branch of mathematics created principally by the
German mathematician Georg Cantor at the end of
the 19th century. Initially controversial, set theory
has come to play the role of a foundational theory
in modern mathematics, in the sense of a theory
invoked to justify assumptions made in mathematics
concerning the existence of mathematical objects
(such as numbers or functions) and their properties.
Formal versions of set theory also have a foundational
role to play as specifying a theoretical ideal
of mathematical rigor in proofs.”
Given this importance of sets, being the basis of mathematics, a set of eccentric theorist set off to
construct a supercomputer operating on sets instead of numbers. The initial SetStack Alpha is under
construction, and they need you to simulate it in order to verify the operation of the prototype.
The computer operates on a single stack of sets, which is initially empty. After each operation, the
cardinality of the topmost set on the stack is output. The cardinality of a set S is denoted |S| and is the
number of elements in S. The instruction set of the SetStack Alpha is PUSH, DUP, UNION, INTERSECT,
and ADD.
• PUSH will push the empty set {} on the stack.
• DUP will duplicate the topmost set (pop the stack, and then push that set on the stack twice).
• UNION will pop the stack twice and then push the union of the two sets on the stack.
• INTERSECT will pop the stack twice and then push the intersection of the two sets on the stack.
• ADD will pop the stack twice, add the first set to the second one, and then push the resulting set
on the stack.
For illustration purposes, assume that the topmost element of the stack is
A = {{}, {{}}}
and that the next one is
B = {{}, {{{}}}}
For these sets, we have |A| = 2 and |B| = 2. Then:
• UNION would result in the set {{}, {{}}, {{{}}}}. The output is 3.
• INTERSECT would result in the set {{}}. The output is 1.
• ADD would result in the set {{}, {{{}}}, {{},{{}}}}. The output is 3.
Input
An integer 0 ≤ T ≤ 5 on the first line gives the cardinality of the set of test cases. The first line of each
test case contains the number of operations 0 ≤ N ≤ 2000. Then follow N lines each containing one of
the five commands. It is guaranteed that the SetStack computer can execute all the commands in the
sequence without ever popping an empty stack.
Output
For each operation specified in the input, there will be one line of output consisting of a single integer.
This integer is the cardinality of the topmost element of the stack after the corresponding command
has executed. After each test case there will be a line with ‘***’ (three asterisks).
Sample Input
2
9
PUSH
DUP
ADD
PUSH
ADD
DUP
ADD
DUP
UNION
5
PUSH
PUSH
ADD
PUSH
INTERSECT
Sample Output
0
0
1
0
1
1
2
2
2
***
0
0
1
0
0
***

紫书(116页)(算法竞赛与入门经典2)

题意:

PUSH: 空集 “{}” 入栈

DUP: 把当前栈顶元素复制一份后入栈;

UNION: 出栈两个集合,把二者的并集入栈;

INTERSECT : 出栈两个集合,把二者的交集入栈;

ADD: 出栈两个集合,把先出栈的集合加入到后出栈的集合中,把结果入栈

每次操作后,输出元素大小

分析:本题的集合并不是简单的整数集合或者字符串集合,而是集合的集合。为了方便起见,此处为每个不同的集合分配一个唯一的ID,则每个集合都可以表示成所包含元素的ID集合,这样就可以用STL的set<int> 来表示了,而整个栈则是一个stack<int>。

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <vector>
#include <map>
#include <string>
#include <queue>
#include <stack>
#include <set>
using namespace std;
typedef long long ll;

#define ALL(x) x.begin(),x.end()//所有的内容
#define INS(x) inserter(x,x.begin())//插入迭代器
typedef set<int> Set;
map <Set,int> IDcache;//把集合映射成ID
vector <Set> Setcache;//根据ID取集合

//查找给定集合x的ID,如果找不到,分配一个新的ID
int ID(Set x)
{
    if(IDcache.count(x))  return IDcache[x];
    Setcache.push_back(x);//添加新集合
    return IDcache[x] = Setcache.size()-1;
}
/*
对任意的集合s(类型是Set),IDcache[s]是它的ID,而Setcache[IDcache[s]]就是它本身,
所以IDcache[s]的范围是0---(n-1),所以,IDcache[x] = Setcache.size()-1;
*/

int main()
{
    stack <int> s;//题目中的栈
    int t;
    cin >> t;
    while(t--){
    int n;
    cin >> n;
    for(int i = 0;i < n;i++){
        string op;
        cin >> op;
        if(op[0] == 'P') s.push(ID(Set()));
        else if(op[0] == 'D') s.push(s.top());
        else{
            Set x1 = Setcache[s.top()]; s.pop();
            Set x2 = Setcache[s.top()]; s.pop();
            Set x;
            //set_union   和  set_intersection都是STL内置的集合操作
            if(op[0] == 'U') set_union (ALL(x1),ALL(x2),INS(x));//把x1,x2并集插入x中
            if(op[0] == 'I') set_intersection(ALL(x1),ALL(x2),INS(x));//把x1,x2交集插入x中
            if(op[0] == 'A') x = x2,x.insert(ID(x1));
            s.push(ID(x));
        }
        cout <<Setcache[s.top()].size() << endl;
    }
    cout << "***" << endl;
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42754600/article/details/81233064