Backward Digit Sums POJ3187 -

Backward Digit Sums

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)

Total Submission(s) : 8   Accepted Submission(s) : 6

Problem Description

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this:
 

    3   1   2   4

      4   3   6

        7   9

         16

Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities.

Write a program to help FJ play the game and keep up with the cows.

Input

Line 1: Two space-separated integers: N and the final sum.

Output

Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.

Sample Input

 

4 16

Sample Output

 

3 1 2 4

题意:输入一个1-9的数n,输入一个sum,将 1-n进行排列,按照杨辉三角相加,结果等于sum的输出字典序排列的n个数

思路:看代码

​#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int main()
{
    int n,m;
    int a[10],b[10];
    cin>>n>>m;
    for(int i=1;i<=n;i++)
    {
        a[i]=i;
    }
    while(1)
    {
        for(int i=1;i<=n;i++)
        {
            b[i]=a[i];
        }
        for(int j=1;j<=n;j++)
        {
            for(int k=1;k<=n-j;k++)
            {
                b[k]+=b[k+1];
            }
        }
        if(b[1]==m) break;

        next_permutation(a+1,a+1+n);
    }
    for(int i=1;i<=n;i++)
    {
        cout<<a[i]<<" ";
    }
    return 0;
}
​

Source

PKU

猜你喜欢

转载自blog.csdn.net/sunpeishuai/article/details/81234848