Not Found

题目描述

You are given a string S consisting of lowercase English letters. Find the lexicographically (alphabetically) smallest lowercase English letter that does not occur in S. If every lowercase English letter occurs in S, print None instead.

Constraints
1≤|S|≤105 (|S| is the length of string S.)
S consists of lowercase English letters.

输入

Input is given from Standard Input in the following format:
S

输出

Print the lexicographically smallest lowercase English letter that does not occur in S. If every lowercase English letter occurs in S, print None instead.

样例输入

atcoderregularcontest

样例输出

b

提示

The string atcoderregularcontest contains a, but does not contain b.

题解:水题,将字符串所有字母都编程数字加入相同数组,最后扫一次看是否有字母没有出现过。

#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{
    int a[30]={0},i=0,k=-1,s;
    string str;
    cin>>str;
    while(str[i])//将字符串所有字母读入
    {
        s=str[i]-'a'+1;
        a[s]++;
        i++;
    }
    for(int j=1;j<=26;j++)//26个字母扫一遍,遇0停止
    {
        if(a[j]==0)
        {
            k=1;
            printf("%c\n",'a'+j-1);
            break;
        }
    }
    if(k==-1)
    {
        cout<<"None"<<endl;
    }
}

猜你喜欢

转载自blog.csdn.net/WN_795/article/details/81217838