1098 Insertion or Heap Sort (25)(25 分)

1098 Insertion or Heap Sort (25)(25 分)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. At each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Heap Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9

Sample Output 2:

Heap Sort
5 4 3 1 0 2 6 7 8 9
#include <bits/stdc++.h>
using namespace std;
const int maxn = 100 + 10;
int n;
int origin[maxn], tempOri[maxn], target[maxn];
void showArray(int a[]) {
	for (int i = 1; i <= n; i++) {
		if (i == 1) cout << a[i];
		else cout << " " << a[i];
	}
	cout << endl;
}
bool isSame() {
	for (int i = 1; i <= n; i++) {
		if (tempOri[i] != target[i]) return false;
	}
	return true;
}
bool insertSort() {
	bool flag = false;
	for (int i = 2; i <= n; i++) {
		if (i != 2 && isSame()) {
			flag = true;
		}
		int temp = tempOri[i], j = i;
		while (j > 1 && tempOri[j - 1] > temp) {
			tempOri[j] = tempOri[j - 1];
			j--;
		}
		tempOri[j] = temp;
		if (flag == true) break;
	}
	return flag;
}
//调整大顶堆,在已经建立好的基础下;
void downAjust(int low, int high) {
	int i = low, j = i*2;//j为左孩子结点
	while (j <= high) {//存在孩子结点
		//如果存在右孩子,并且右孩子结点的值大于左孩子结点的值
		if (j + 1 <= high && tempOri[j + 1] > tempOri[j]) {
			j++;
		}
		if (j <= high && tempOri[j] > tempOri[i]) {
			swap(tempOri[j], tempOri[i]);
			i = j;
		}
		else {
			break;
		}
		j=i*2;
	}
}

void heapSort() {
	bool flag = false;
	//因为最后要求升序,所以先建大顶堆;先从非叶子结点开始
	for (int i = n/2; i >= 1; i--) {
		downAjust(i, n);//建堆
	}
	for (int i = n; i > 1; i--) {
		if (i != n && isSame()) {
			flag = true;
		}
		swap(tempOri[i], tempOri[1]);//与堆顶交换
		downAjust(1, i-1);//调整堆顶
		if (flag == true) {
			showArray(tempOri);
			return;
		} 
	}
}
void init() {
	memset(origin, 0, sizeof(origin));
	memset(tempOri, 0, sizeof(tempOri));
	memset(target, 0, sizeof(target));
}
int main() {
	init();
	scanf("%d", &n);
	for (int i = 1; i <= n; i++) {
		scanf("%d", &origin[i]);
		tempOri[i] = origin[i];
	}

	for (int i = 1; i <= n; i++) {
		cin >> target[i];
	}
	if (insertSort()) {
		printf("Insertion Sort\n");
		showArray(tempOri);
	}
	else {
		//还原数组
		for (int i = 1; i <= n; i++) {
			tempOri[i] = origin[i];
		}
		printf("Heap Sort\n");
		heapSort();
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_34649947/article/details/81163555