Stones

Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time. 
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first. 

Input

In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases. 
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.

Output

Just output one line for one test case, as described in the Description.

Sample Input

2
2
1 5
2 4
2
1 5
6 6

Sample Output

11
12

题意:奇数把石头扔出去,偶数不管当前的石头,遇到相同地点的石头,视作先遇到扔得近的。

用优先队列去完成

#include<iostream>
#include<algorithm>
#include<queue>
#include<cstdio>
using namespace std;
int n,m;
struct Node{
	int p;
	int d;
	bool operator <(Node b) const{
		if(p!=b.p)
		    return p>b.p;
		else
		    return d>b.d;
	}
}nowNode;
int main()    
{
	while(scanf("%d",&n)!=EOF)
	{
		priority_queue<Node>q;
		while(n--)
		{
			scanf("%d",&m);
			for(int i=0;i<m;i++)
			{
				int nowp,nowd;
				scanf("%d%d",&nowNode.p,&nowNode.d);
				q.push(nowNode);
			}
			int count=0;
			while(!q.empty())
			{
				count++;
				nowNode=q.top();
				q.pop();
				if(count&1)
				{
					nowNode.p=nowNode.p+nowNode.d;
					q.push(nowNode);
				}
			}
			cout<<nowNode.p<<endl;;
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/cysisu/article/details/81188856