[USACO14DEC] 驮运Piggy Back

题目描述

Bessie and her sister Elsie graze in different fields during the day, and in the evening they both want to walk back to the barn to rest. Being clever bovines, they come up with a plan to minimize the total amount of energy they both spend while walking.

Bessie spends B units of energy when walking from a field to an adjacent field, and Elsie spends E units of energy when she walks to an adjacent field. However, if Bessie and Elsie are together in the same field, Bessie can carry Elsie on her shoulders and both can move to an adjacent field while spending only P units of energy (where P might be considerably less than B+E, the amount Bessie and Elsie would have spent individually walking to the adjacent field). If P is very small, the most energy-efficient solution may involve Bessie and Elsie traveling to a common meeting field, then traveling together piggyback for the rest of the journey to the barn. Of course, if P is large, it may still make the most sense for Bessie and Elsie to travel

separately. On a side note, Bessie and Elsie are both unhappy with the term "piggyback", as they don't see why the pigs on the farm should deserve all the credit for this remarkable form of

transportation.

Given B, E, and P, as well as the layout of the farm, please compute the minimum amount of energy required for Bessie and Elsie to reach the barn.

Bessie 和 Elsie在不同的区域放牧,他们希望花费最小的能量返回谷仓。从一个区域走到一个相连区域,Bessie要花费B单位的能量,Elsie要花费E单位的能量。

如果某次他们两走到同一个区域,Bessie 可以背着 Elsie走路,花费P单位的能量走到另外一个相连的区域。当然,存在P>B+E的情况。

相遇后,他们可以一直背着走,也可以独立分开。

输入输出格式

输入格式:

INPUT: (file piggyback.in)

The first line of input contains the positive integers B, E, P, N, and M. All of these are at most 40,000. B, E, and P are described above. N is the number of fields in the farm (numbered 1..N, where N >= 3), and M is the number of connections between fields. Bessie and Elsie start in fields 1 and 2, respectively. The barn resides in field N.

The next M lines in the input each describe a connection between a pair of different fields, specified by the integer indices of the two fields. Connections are bi-directional. It is always possible to travel from field 1 to field N, and field 2 to field N, along a series of such connections.

输出格式:

OUTPUT: (file piggyback.out)

A single integer specifying the minimum amount of energy Bessie and

Elsie collectively need to spend to reach the barn. In the example

shown here, Bessie travels from 1 to 4 and Elsie travels from 2 to 3

to 4. Then, they travel together from 4 to 7 to 8.

输入输出样例

输入样例#1: 
4 4 5 8 8 
1 4 
2 3 
3 4 
4 7 
2 5 
5 6 
6 8 
7 8 
输出样例#1: 
22 



贪心一下, 我们最后的答案一定是两人同时经过一个节点, 然后一起走到终点(这个节点可能为根节点,代表中间不一起走)。
于是我们跑三遍spfa,算出来三个花费的最短路,然后按照上面的贪心思路算出答案,取min就行了。
貌似有复杂度更小的方法...直接bfs, 可以做到O(n),然后算花费直接乘b,e,p...
这样O(N)解决, 貌似比我的更优...不过都能AC就不管了...


 
#include <iostream>
#include <cstdio> 
#include <queue>
#include <cstring>
using namespace std;

int b, e, p, n, m;
int dis1[40005], dis2[40005], dis3[40005];
struct edge{
    int nxt, to;
}ed[1000005];
int head[40005], cnt;
inline void add(int x, int y)
{
    ed[++cnt] = (edge){head[x], y};
    head[x] = cnt;
}
bool ex[40005];

int main()
{
    scanf("%d%d%d%d%d", &b, &e, &p, &n, &m);
    for (int i = 1 ; i <= m ; i ++)
    {
        int x, y;
        scanf("%d%d", &x, &y);
        add(x, y), add(y, x);
    }
    
    queue <int> q;
    q.push(1);
    memset(dis1, 0x3f, sizeof dis1);
    dis1[1] = 0;
    ex[1] = 1;
    while(!q.empty())
    {
        int x = q.front();q.pop();ex[x] = 0;
        for (int i = head[x] ; i ; i = ed[i].nxt)
        {
            int to = ed[i].to;
            if (dis1[to] > dis1[x] + b)
            {
                dis1[to] = dis1[x] + b;
                if (!ex[to]) {ex[to] = 1;q.push(to);}
            }
        }
    }
    
    q.push(2);
    memset(dis2, 0x3f, sizeof dis2);
    memset(ex, 0, sizeof ex);
    dis2[2] = 0;
    ex[2] = 1;
    while(!q.empty())
    {
        int x = q.front();q.pop();ex[x] = 0;
        for (int i = head[x] ; i ; i = ed[i].nxt)
        {
            int to = ed[i].to;
            if (dis2[to] > dis2[x] + e)
            {
                dis2[to] = dis2[x] + e;
                if (!ex[to]) {ex[to] = 1;q.push(to);}
            }
        }
    }    
    
    q.push(n);
    memset(dis3, 0x3f, sizeof dis3);
    memset(ex, 0, sizeof ex);
    dis3[n] = 0;
    ex[n] = 1;
    while(!q.empty())
    {
        int x = q.front();q.pop();ex[x] = 0;
        for (int i = head[x] ; i ; i = ed[i].nxt)
        {
            int to = ed[i].to;
            if (dis3[to] > dis3[x] + p)
            {
                dis3[to] = dis3[x] + p;
                if (!ex[to]) {ex[to] = 1;q.push(to);}
            }
        }
    }    
    
    int ans = 1e9;
    for (int i = 1 ; i <= n ; i ++)
    {
        ans = min(ans, dis1[i] + dis2[i] + dis3[i]);
    }
    printf("%d\n", ans);
    return 0;
}
 
    
   

猜你喜欢

转载自www.cnblogs.com/zZh-Brim/p/9351121.html