UVALive - 3708 Graveyard (思维)

Programming contests became so popular in the year 2397 that the governor of New Earck — the largest human-inhabited planet of the galaxy — opened a special Alley of Contestant Memories (ACM) at the local graveyard. The ACM encircles a green park, and holds the holographic statues of famous contestants placed equidistantly along the park perimeter. The alley has to be renewed from time to time when a new group of memorials arrives. When new memorials are added, the exact place for each can be selected arbitrarily along the ACM, but the equidistant disposition must be maintained by moving some of the old statues along the alley. Surprisingly, humans are still quite superstitious in 24th century: the graveyard keepers believe the holograms are holding dead people souls, and thus always try to renew the ACM with minimal possible movements of existing statues (besides, the holographic equipment is very heavy). Statues are moved along the park perimeter. Your work is to find a renewal plan which minimizes the sum of travel distances of all statues. Installation of a new hologram adds no distance penalty, so choose the places for newcomers wisely!
Input
The input file contains several test cases, each of them consists of a a line that contains two integer numbers: n — the number of holographic statues initially located at the ACM, and m — the number of statues to be added (2 ≤ n ≤ 1000, 1 ≤ m ≤ 1000). The length of the alley along the park perimeter is exactly 10 000 feet.
Output
For each test case, write to the output a line with a single real number — the minimal sum of travel distances of all statues (in feet). The answer must be precise to at least 4 digits after decimal point.
Note: Pictures show the first three examples. Marked circles denote original statues, empty circles denote new equidistant places, arrows denote movement plans for existing statues.
Sample Input
2 1

2 3

3 1

10 10
Sample Output
1666.6667

1000.0

1666.6667

0.0

白书解释:为什么不会有两个雕塑移动到一个相同的位置?因为一开始认为周长是m+n,只有n个雕塑,长度是一定会大于一的。而想出现两个雕塑到同一个坑的情况,只有是0.5,1.4999.....类似这样的两个雕塑距离为一的情况,这种情况不可能存在。

#include<algorithm>
#include<string.h>
#include<stdio.h>
#include<cmath>
using namespace std;
int main()
{
    int n,m;
    double pos,ans;
    while(~scanf("%d%d",&n,&m))
    {
        ans=0.0;
        for(int i=1;i<n;i++)
        {
            pos=(double)(n+m)/n*i;
            ans+=fabs(pos-floor(pos+0.5))/(n+m);
        }
        printf("%.4lf\n",ans*10000);
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_41380961/article/details/81075584