HDU 2647 Reward(拓扑排序)

Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.

Input

One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.

Output

For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.

Sample Input

2 1
1 2
2 2
1 2
2 1

Sample Output

1777
-1

这题视乎和Tarjan有点像,应该可以用Tarjan来做。没试过,不知道。只是感觉能行。

#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<vector>
#include<queue>
#define M 10010
using namespace std;
struct node
{
    int r,v;
};
queue<node>q;
vector<int>p[M];
int pan[M],carry[M];
int l,r,n,m;
void init()
{
    for(int i=1;i<=n;i++)
    {
        p[i].clear();
    }
    memset(pan,0,sizeof(pan));
    memset(carry,0,sizeof(carry));
}
int main()
{
    int ans;
    while(~scanf("%d%d",&n,&m))
    {
        ans=0;
        init();
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&l,&r);
            p[r].push_back(l);
            pan[l]++;
        }
        node a,b;
        for(int i=1;i<=n;i++)
        {
            if(!pan[i])
            {
                a.r=i;
                a.v=888;
                q.push(a);
            }
        }
        while(!q.empty())
        {
            b=q.front();
            q.pop();
            ans+=b.v;
            carry[b.r]=1;
            for(int i=0;i<p[b.r].size();i++)
            {
                int d=p[b.r][i];
                pan[d]--;
                if(!pan[d])
                {
                    a.r=d;
                    a.v=b.v+1;
                    q.push(a);
                }
            }
        }
        for(int i=1;i<=n;i++)
        {
            if(!carry[i])
            {
                ans=-1;
                break;
            }
        }
        printf("%d\n",ans);
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_41380961/article/details/81106905