结构体排序 查找(map)

总结:map是个很好用的东西,用map存下名字用数字代替很方便


Song Jiang's rank list

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 168    Accepted Submission(s): 91


Problem Description
《Shui Hu Zhuan》,also 《Water Margin》was written by Shi Nai'an -- an writer of Yuan and Ming dynasty. 《Shui Hu Zhuan》is one of the Four Great Classical Novels of Chinese literature. It tells a story about 108 outlaws. They came from different backgrounds (including scholars, fishermen, imperial drill instructors etc.), and all of them eventually came to occupy Mout Liang(or Liangshan Marsh) and elected Song Jiang as their leader.

In order to encourage his military officers, Song Jiang always made a rank list after every battle. In the rank list, all 108 outlaws were ranked by the number of enemies he/she killed in the battle. The more enemies one killed, one's rank is higher. If two outlaws killed the same number of enemies, the one whose name is smaller in alphabet order had higher rank. Now please help Song Jiang to make the rank list and answer some queries based on the rank list.
 

Input
There are no more than 20 test cases.

For each test case:

The first line is an integer N (0<N<200), indicating that there are N outlaws.

Then N lines follow. Each line contains a string S and an integer K(0<K<300), meaning an outlaw's name and the number of enemies he/she had killed. A name consists only letters, and its length is between 1 and 50(inclusive). Every name is unique. 

The next line is an integer M (0<M<200) ,indicating that there are M queries.

Then M queries follow. Each query is a line containing an outlaw's name. 
The input ends with n = 0
 

Output
For each test case, print the rank list first. For this part in the output ,each line contains an outlaw's name and the number of enemies he killed. 

Then, for each name in the query of the input, print the outlaw's rank. Each outlaw had a major rank and a minor rank. One's major rank is one plus the number of outlaws who killed more enemies than him/her did.One's minor rank is one plus the number of outlaws who killed the same number of enemies as he/she did but whose name is smaller in alphabet order than his/hers. For each query, if the minor rank is 1, then print the major rank only. Or else Print the major rank, blank , and then the minor rank. It's guaranteed that each query has an answer for it.
 

Sample Input
5WuSong 12LuZhishen 12SongJiang 13LuJunyi 1HuaRong 155WuSongLuJunyiLuZhishenHuaRongSongJiang0
 
Sample Output
HuaRong 15SongJiang 13LuZhishen 12WuSong 12LuJunyi 13 25312
 

Source
题意: 
按照杀人数从大到小输出,杀人数相同,按名字字典序从小到大规则输出。
然后输入一个名字,输出杀人数大于他自己的人数+1;之后输出名字的字典序

小于他自己并且杀人数相同人数+1,如果这个数为1则不用输出。


#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
#include<map>
#define N 0x3f3f3f3f
using namespace std;
struct ac
{
	string s;
	int a,b,c;
}r[202];
int cmp(ac x,ac y)
{
	if(x.a==y.a)
	return x.s<y.s;
	return x.a>y.a;
}
int main()
{
	int n;
	while(cin>>n)
	{
		if(n==0)
		break;
		for(int i=0;i<n;i++)
		{
			cin>>r[i].s>>r[i].a;
		}
		sort(r,r+n,cmp);
		int len=1;
		map<string,int>mp;
		for(int i=0;i<n;i++)
		{
			mp[r[i].s]=i;
			r[i].b=i+1;
			r[i].c=1;
			cout<<r[i].s<<" "<<r[i].a<<endl;
		}
		for(int i=1;i<n;i++)
		{
			if(r[i].a==r[i-1].a)
			{
				r[i].c=r[i-1].c+1;
				r[i].b=r[i-1].b;
			}
			
		}
		int m;
		cin>>m;
		string ss;
		for(int i=0;i<m;i++)
		{
			cin>>ss;
			if(r[mp[ss]].c==1)
			{
				cout<<r[mp[ss]].b<<endl;
			}
			else
			cout<<r[mp[ss]].b<<" "<<r[mp[ss]].c<<endl;
		}
		
	}
	return 0;
	
	
} 

猜你喜欢

转载自blog.csdn.net/henucm/article/details/80995428
今日推荐