CCF试题Java-相邻数对

import java.util.Arrays;
import java.util.Scanner;

/**
 *  给定n个不同的整数,问这些数中有多少对整数,它们的值正好相差1。
	输入格式
  输入的第一行包含一个整数n,表示给定整数的个数。第二行包含所给定的n个整数。
	输出格式
  输出一个整数,表示值正好相差1的数对的个数。
	样例输入
	6
	10 2 6 3 7 8
	样例输出
	3
	样例说明
  值正好相差1的数对包括(2, 3), (6, 7), (7, 8)。
	评测用例规模与约定
  1<=n<=1000,给定的整数为不超过10000的非负整数。
 * @author Administrator
 *
 */
public class One {

	public static void main(String[] args) {

		Scanner sc = new Scanner(System.in);
		int n = sc.nextInt();
		int[] count = new int[n];
		int temp = 0;
		for(int i = 0 ; i < n ; i++) {
			temp = sc.nextInt();
			count[i] = temp;
		}
		
		Arrays.sort(count);
		int check = 0;
		
		for(int i = 0 ; i < n-1 ; i++) {
			if((count[i+1]-count[i])==1) {
				check++;
			}
		}
		
		System.out.println(check);
	}

}

猜你喜欢

转载自blog.csdn.net/kidchildcsdn/article/details/81062107
今日推荐