What Are You Talking About-HDU1075

What Are You Talking About

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)
Total Submission(s): 27431    Accepted Submission(s): 9328


Problem Description
Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
 

Input
The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
 

Output
In this problem, you have to output the translation of the history book.
 

Sample Input
 
  
STARTfrom fiwohello difhmars riwosfearth fnnvklike fiiwjENDSTARTdifh, i'm fiwo riwosf.i fiiwj fnnvk!END
 

Sample Output
 
  
hello, i'm from mars.i like earth!
Hint
Huge input, scanf is recommended.
 

Author
Ignatius.L
 

思路:很明显的字典树,暂时不会TAT,map写法思路直接看代码注释吧!

代码:

#include<iostream>
#include<string>
#include<map>
using namespace std;
int main()
{
	ios::sync_with_stdio(false);
	map<string,string>mp;
	string str,str2;
	cin>>str;//合理处START... 
	while(cin>>str){
		if(str=="END") break;
		cin>>str2;
		mp[str2]=str;
	}
	cin>>str;//合理处理START
	getchar();
	while(getline(cin,str)){
		if(str=="END") break;
		str2.clear();
		map<string,string> ::iterator it; //map的迭代器 
		for(int i=0;i<str.size();i++){
			if(str[i]>='a'&&str[i]<='z') str2+=str[i];
			else{
				if(str2.size()){//如果之前记录了str2则输出 
					it=mp.find(str2);
					if(it==mp.end()) cout<<str2;//如果map没有记录则原样输出
				    else cout<<mp[str2];
				    str2.clear();
				}
				cout<<str[i];//非字符原样输出 
			}
		}
		cout<<endl;
	}
} 

猜你喜欢

转载自blog.csdn.net/DaDaguai001/article/details/81051910