PAT1001 A+B Format C语言

1001 A+B Format (20)(20 分)

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991

解题分析:

这道题我最开始提交的时候发现只有15分有部分错误,那部分错误在哪呢。认真再分析了题目后发现如果不判断后面的数字中是否含有0,就会造成0输出被省掉的错误比如:100000 1 本应该输出 100,001但是如果不判断的话输出为100,1就会产生错误。为了方便后面判断及输出可以采取一部分一部分的输出。

代码:#include<stdio.h>
int main()
{
int a,b,sum,t,k;
scanf("%d%d",&a,&b);
sum=a+b;
if(sum<1000&&sum>-1000)
printf("%d\n",sum);
else
{t=sum%1000;
if(t<0)t=t*-1;
sum=sum/1000;
if(sum<1000&&sum>-1000)
{if(t<10)
    printf("%d,00%d\n",sum,t);
else if(t<100)
    printf("%d,0%d\n",sum,t);
else if(t>100)
    printf("%d,%d\n",sum,t);
}
else
{k=sum%1000;
if(k<0)k=k*-1;
sum=sum/1000;
printf("%d,",sum);
if(k<10)
    printf("00%d,",k);
else if(k<100)
    printf("0%d,",k);
else if(k>100)
    printf("%d\n",k);
if(t<10)
    printf("00%d\n",t);
else if(t<100)
    printf("0%d\n",t);
else if(t>100)
    printf("%d\n",t);
}
}
return 0;
}

猜你喜欢

转载自blog.csdn.net/lhkjg/article/details/81016846
今日推荐