[ALGO-49] 寻找数组中最大值


算法训练 寻找数组中最大值  
时间限制:1.0s   内存限制:512.0MB
    
问题描述
  对于给定整数数组a[],寻找其中最大值,并返回下标。
输入格式
  整数数组a[],数组元素个数小于1等于100。输出数据分作两行:第一行只有一个数,表示数组元素个数;第二行为数组的各个元素。
输出格式
  输出最大值,及其下标
样例输入
3
3 2 1


样例输出

3 0



import java.util.Arrays;
import java.util.Scanner;

public class ALGO49 {

	public static void main(String[] args) {
		// TODO 自动生成的方法存根
		Scanner console = new Scanner(System.in);
		int N = console.nextInt();
		int a[] = new int[N]; 
		int b[] = new int[N];
		int max;
		for(int i = 0; i < N;i++){
			a[i] = console.nextInt();
		}
		System.arraycopy(a, 0, b, 0, a.length);
		Arrays.sort(b);
		max = b[N-1];
		for(int i = 0; i < N;i++){
			if(a[i] == max){
				System.out.print(max+" ");
				System.out.print(i+" ");
			}
		}
	}
}

猜你喜欢

转载自blog.csdn.net/qq_40395278/article/details/79634140