最基础的OJ,HDU1089-1096

HDU 1000

Problem Description

Calculate A + B.

 

Input

Each line will contain two integers A and B. Process to end of file.

 

Output

For each case, output A + B in one line.

 

Sample Input

1 1

 

Sample Output

2

正确

# include <stdio.h>

int main ()

{

int a,b;

while(scanf("%d%d",&a,&b)!=EOF)

printf("%d\n",a+b);

return 0;

}

HDU 1001

Problem Description

Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.

Input

The input will consist of a series of integers n, one integer per line.

 

Output

For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

 

Sample Input

1

100

 

Sample Output

1

5050

AC:

#include<stdio.h>

int main()

{

 int n,sum;

 while(scanf("%d",&n)!=EOF)

 {

  sum=n/2.0*(n+1);

  printf("%d\n\n",sum);

 }

 return 0;

}  

AC↘分析:不能在第四行给sum赋初值,不然每次运算后sum的值不为0

#include<stdio.h>

int main()

{

 int i,n,sum;

 while(scanf("%d",&n)!=EOF)

 {

  sum=0;

    for(i=1;i<=n;i++)

sum=sum+i;

printf("%d\n\n",sum);

 }

 return 0;

}

1089

Problem Description

Your task is to Calculate a + b.
Too easy?! Of course! I specially designed the problem for acm beginners.
You must have found that some problems have the same titles with this one, yes, all these problems were designed for the same aim.

 

Input

The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line.

 

Output

For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

 

Sample Input

1 5

10 20

 

Sample Output

6

30

# include <stdio.h>

int main ()

{

int a,b;

while(scanf("%d%d",&a,&b)!=EOF)

printf("%d\n",a+b);

return 0;

}

1090

Problem Description

Your task is to Calculate a + b.

 

Input

Input contains an integer N in the first line, and then N lines follow. Each line consists of a pair of integers a and b, separated by a space, one pair of integers per line.

 

Output

For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

 

Sample Input

2

1 5

10 20

 

Sample Output

6

30

#include<stdio.h>

int main()

{

    int n,a,b;

    scanf("%d",&n);

    while(n--)

    {

    scanf("%d%d",&a,&b);

    printf("%d\n",a+b);

    }

    return 0;

}

1091

Problem Description

Your task is to Calculate a + b.

 

Input

Input contains multiple test cases. Each test case contains a pair of integers a and b, one pair of integers per line. A test case containing 0 0 terminates the input and this test case is not to be processed.

 

Output

For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

 

Sample Input

1 5

10 20

0 0

 

Sample Output

6

30

#include<iostream>

using namespace std;

int main()

{

int a,b;

while(cin>>a>>b&&(a||b))

cout<<a+b<<endl;

return 0;

}

1092

Problem Description

Your task is to Calculate the sum of some integers.

 

Input

Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.

 

Output

For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

 

Sample Input

4 1 2 3 4

5 1 2 3 4 5

0

 

Sample Output

10

15

#include<stdio.h>

int main()

{

  int n,i,a,sum;

  while(scanf("%d",&n)!=EOF)

  { if(n)

    {

     sum=0;

     for(i=1;i<=n;i++)

     {

     scanf("%d",&a);

     sum+=a;

     }

    printf("%d\n",sum);

    }

  }

    return 0;

}

1093

Problem Description

Your task is to calculate the sum of some integers.

 

Input

Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

 

Output

For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

 

Sample Input

2

4 1 2 3 4

5 1 2 3 4 5

 

Sample Output

10

15

正确

#include<stdio.h>

  int main()

{

      int i,m,n,a,sum;

      scanf("%d",&m);

      while(m--)

      {

        scanf("%d",&n);

        sum=0;

        for(i=1;i<=n;i++)

        {

        scanf("%d",&a);

        sum+=a;

        }

        printf("%d\n",sum);

      }

     return 0;

}

1094

Problem Description

Your task is to calculate the sum of some integers.

 

Input

Input contains multiple test cases, and one case one line. Each case starts with an integer N, and then N integers follow in the same line.

 

Output

For each test case you should output the sum of N integers in one line, and with one line of output for each line in input.

 

Sample Input

4 1 2 3 4

5 1 2 3 4 5

 

Sample Output

10

15

正确

#include<stdio.h>

int main()

{

  int n,i,a,sum;

  while(scanf("%d",&n)!=EOF)

  {

sum=0;

    for(i=1;i<=n;i++)

    {

    scanf("%d",&a);

    sum+=a;

    }

    printf("%d\n",sum);

  }

    return 0;

}

1095

Problem Description

Your task is to Calculate a + b.

 

Input

The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line.

 

Output

For each pair of input integers a and b you should output the sum of a and b, and followed by a blank line.

 

Sample Input

1 5

10 20

 

Sample Output

6

30

#include<stdio.h>
int main()
{
    int a,b;
    while(scanf("%d%d",&a,&b)!=EOF)
    {
       printf("%d\n\n",a+b);

    }
    return 0;
}

1096

Problem Description

Your task is to calculate the sum of some integers.

 

Input

Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

 

Output

For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.

 

Sample Input

3

4 1 2 3 4

5 1 2 3 4 5

3 1 2 3

 

Sample Output

10

15

6

#include<stdio.h>
int main()
{
 int l;
 scanf("%d",&l);
 while(l--)
 {
  int m,k,sum=0;
  scanf("%d",&m);
  for(int i=0;i<m;i++)
  {
   scanf("%d",&k);
   sum+=k;
  }
  printf("%d\n",sum);
  if(l!=0) printf("\n");
 }
 return 0;
}

 

猜你喜欢

转载自blog.csdn.net/tingtingyuan/article/details/79789136