pat 1059 C语言竞赛

1059 C语言竞赛(20 分)

C 语言竞赛是浙江大学计算机学院主持的一个欢乐的竞赛。既然竞赛主旨是为了好玩,颁奖规则也就制定得很滑稽:

  • 0、冠军将赢得一份“神秘大奖”(比如很巨大的一本学生研究论文集……)。
  • 1、排名为素数的学生将赢得最好的奖品 —— 小黄人玩偶!
  • 2、其他人将得到巧克力。

给定比赛的最终排名以及一系列参赛者的 ID,你要给出这些参赛者应该获得的奖品。

输入格式:

输入第一行给出一个正整数 N(104​​),是参赛者人数。随后 N 行给出最终排名,每行按排名顺序给出一位参赛者的 ID(4 位数字组成)。接下来给出一个正整数 K 以及 K 个需要查询的 ID。

输出格式:

对每个要查询的 ID,在一行中输出 ID: 奖品,其中奖品或者是 Mystery Award(神秘大奖)、或者是 Minion(小黄人)、或者是 Chocolate(巧克力)。如果所查 ID 根本不在排名里,打印 Are you kidding?(耍我呢?)。如果该 ID 已经查过了(即奖品已经领过了),打印 ID: Checked(不能多吃多占)。

输入样例:

6
1111
6666
8888
1234
5555
0001
6
8888
0001
1111
2222
8888
2222

输出样例:

8888: Minion
0001: Chocolate
1111: Mystery Award
2222: Are you kidding?
8888: Checked
2222: Are you kidding?

尝试用hash进行存储,我构造了一个结构体数组作为hash,用来存储每个学号的排名和是否被检查过
#include <iostream>
#include <cmath>
#include <sstream>
using namespace std;

typedef struct{
	int paiming;
	int checked;
}Hash;

int detect(int n)
{
	for(int i=2;i<=sqrt(n);i++)
	{
		if(n%i==0)
		{
			return 0;
		}
	}
	return 1;
}

string transform(int num)
{
 string res;
 stringstream ss;
 ss<<num;
 ss>>res;
 if(num<10)
 {
  res="000"+res;
 }
 else if(num<100)
 {
 	res="00"+res;
 }
 else if(num<1000)
 {
 	res="0"+res;
 }
 return res;
}

int main()
{
	int n,k,i;
	//利用hash存储每个学号的排名
	Hash hash[10000];
	for(i=0;i<10000;i++)
	{
		//记录是否被查询过 
		hash[i].checked=0;
		hash[i].paiming=-1;
	} 
	cin>>n;
	int *id=new int[n];
	for(i=0;i<n;i++)
	{
		cin>>id[i];
		hash[id[i]].paiming=i+1;
	}
	cin>>k;
	int *search=new int[k];
	string *result=new string[k];
	for(i=0;i<k;i++)
	{
		cin>>search[i];
		if(hash[search[i]].checked==1)
		{
			result[i]=": Checked";
		}
		else
		{
			if(hash[search[i]].paiming==-1)
			{
				result[i]=": Are you kidding?";
			}
			else if(hash[search[i]].paiming==1)
			{
				result[i]=": Mystery Award";
				hash[search[i]].checked=1;
			}
			else if(detect(hash[search[i]].paiming))
			{
				result[i]=": Minion";
				hash[search[i]].checked=1;
			}
			else
			{
				result[i]=": Chocolate";
				hash[search[i]].checked=1;
			}
		}
	}
	for(i=0;i<k;i++)
	{
		if(search[i]<1000)
		{
			cout<<transform(search[i])<<result[i]<<endl;
		}
		else
		{
			cout<<search[i]<<result[i]<<endl;
		}
	}
	return 0;
}

  


猜你喜欢

转载自www.cnblogs.com/houchen/p/9254323.html