Atcoder>>E - Independence (二分图染色+dp)+(补图) >>即考虑相反的情况

E - Independence


Time limit : 2sec / Memory limit : 1024MB

Score : 700 points

Problem Statement

In the State of Takahashi in AtCoderian Federation, there are N cities, numbered 1,2,…,NM bidirectional roads connect these cities. The i-th road connects City Ai and City Bi. Every road connects two distinct cities. Also, for any two cities, there is at most one road that directly connects them.

One day, it was decided that the State of Takahashi would be divided into two states, Taka and Hashi. After the division, each city in Takahashi would belong to either Taka or Hashi. It is acceptable for all the cities to belong Taka, or for all the cities to belong Hashi. Here, the following condition should be satisfied:

  • Any two cities in the same state, Taka or Hashi, are directly connected by a road.

Find the minimum possible number of roads whose endpoint cities belong to the same state. If it is impossible to divide the cities into Taka and Hashi so that the condition is satisfied, print -1.

Constraints

  • 2≤N≤700
  • 0≤MN(N−1)⁄2
  • 1≤AiN
  • 1≤BiN
  • AiBi
  • If ij, at least one of the following holds: AiAj and BiBj.
  • If ij, at least one of the following holds: AiBj and BiAj.

Input

Input is given from Standard Input in the following format:

N M
A1 B1
A2 B2
:
AM BM

Output

Print the answer.


Sample Input 1

Copy
5 5
1 2
1 3
3 4
3 5
4 5

Sample Output 1

Copy
4

For example, if the cities 1,2 belong to Taka and the cities 3,4,5 belong to Hashi, the condition is satisfied. Here, the number of roads whose endpoint cities belong to the same state, is 4.


Sample Input 2

Copy
5 1
1 2

Sample Output 2

Copy
-1

In this sample, the condition cannot be satisfied regardless of which cities belong to each state.


Sample Input 3

Copy
4 3
1 2
1 3
2 3

Sample Output 3

Copy
3

Sample Input 4

Copy
10 39
7 2
7 1
5 6
5 8
9 10
2 8
8 7
3 10
10 1
8 10
2 3
7 4
3 9
4 10
3 4
6 1
6 7
9 5
9 7
6 9
9 4
4 6
7 5
8 3
2 5
9 2
10 7
8 6
8 9
7 3
5 3
4 5
6 3
2 10
5 10
4 2
6 2
8 4
10 6

Sample Output 4

Copy
21
#include<bits/stdc++.h>
using namespace std;
int g[701][701],col[701];
int dp[2][701];
int num1,num2,n,x,y,m;
void init(int n){
    for(int i=1;i<=n;i++)for(int j=1;j<=n;j++) 
     if(i!=j) g[i][j]=1;
}
bool dfs(int x,int c){
    if(col[x]==0){
        col[x]=c;
        if(c==1) num1++;
        else num2++;    
    }
    else return col[x]==c;
    for(int i=1;i<=n;i++){
        if(x!=i&&g[x][i]){
            if(!dfs(i,-c)) return 0;
        }
    } 
    return 1;
} 
int main(){
    std::ios::sync_with_stdio(false);
    cin>>n>>m;init(n);
    for(int i=1;i<=m;i++){
        cin>>x>>y;g[x][y]=g[y][x]=0;
    }
    dp[0][0]=1;int cur=0;
    for(int i=1;i<=n;i++){
        if(col[i]==0){
            num1=num2=0;
            if(!dfs(i,1)){cout<<"-1\n";return 0;}
            int suf=cur^1;
            memset(dp[suf],0,sizeof(dp[suf]));
            for(int i=0;i<=n;i++){
                if(dp[cur][i]){
                    dp[suf][i+num1]=dp[suf][i+num2]=1;
                }
            }
            cur=suf;
        } 
    }
    for(int i=n/2;i>=1;i--){
        if(dp[cur][i]){
            cout<<i*(i-1)/2+(n-i)*(n-i-1)/2<<endl;
            return 0;
        }
    }
    return 0;
}
View Code

猜你喜欢

转载自www.cnblogs.com/vainglory/p/9227982.html