试题 算法提高 最小字符串

资源限制

内存限制:256.0MB C/C++时间限制:2.0s Java时间限制:6.0s Python时间限制:10.0s

问题描述

  给定一些字符串(只包含小写字母),要求将他们串起来构成一个字典序最小的字符串。

输入格式

  第一行T,表示有T组数据。

  接下来T组数据

  每组第一行一个正整数n,表示字符串个数。

  接下来n行,每行一个字符串(长度不超过100)。

输出格式

  T行,每行一个字符串。

样例输入

1

3

a

b

c

样例输出

abc

数据规模和约定

  T<=7000,n<=100;

#include<iostream>

#include<algorithm>

using namespace std;

bool cmp(string x,string y){

string x1,y1;

x1=x+y;y1=y+x;

return x1<y1;

}

int main(){

int t;cin>>t;

while(t--){

int n;cin>>n;

string a[110];

for(int i=1;i<=n;i++)cin>>a[i];

sort(a+1,a+1+n,cmp);

for(int i=1;i<=n;i++){

cout<<a[i];

}

cout<<endl;

}

return 0;

}

猜你喜欢

转载自blog.csdn.net/m0_74310050/article/details/129103141