P3605 [USACO17JAN]Promotion Counting晋升者计数

题目描述

The cows have once again tried to form a startup company, failing to remember from past experience that cows make terrible managers!

The cows, conveniently numbered 1 \ldots N1N ( 1 \leq N \leq 100,0001N100,000 ), organize the company as a tree, with cow 1 as the president (the root of the tree). Each cow except the president has a single manager (its "parent" in the tree). Each cow ii has a distinct proficiency rating, p(i)p(i) , which describes how good she is at her job. If cow ii is an ancestor (e.g., a manager of a manager of a manager) of cow jj , then we say jj is a subordinate of ii .

Unfortunately, the cows find that it is often the case that a manager has less proficiency than several of her subordinates, in which case the manager should consider promoting some of her subordinates. Your task is to help the cows figure out when this is happening. For each cow ii in the company, please count the number of subordinates jj where p(j) > p(i)p(j)>p(i) .

奶牛们又一次试图创建一家创业公司,还是没有从过去的经验中吸取教训--牛是可怕的管理者!

为了方便,把奶牛从 1N(1N100,000) 编号,把公司组织成一棵树,1 号奶牛作为总裁(这棵树的根节点)。除了总裁以外的每头奶牛都有一个单独的上司(它在树上的 “双亲结点”)。所有的第 ii 头牛都有一个不同的能力指数 p(i)p(i) ,描述了她对其工作的擅长程度。如果奶牛 ii 是奶牛 jj 的祖先节点(例如,上司的上司的上司),那么我们我们把奶牛 jj 叫做 ii 的下属。

不幸地是,奶牛们发现经常发生一个上司比她的一些下属能力低的情况,在这种情况下,上司应当考虑晋升她的一些下属。你的任务是帮助奶牛弄清楚这是什么时候发生的。简而言之,对于公司的中的每一头奶牛 ii ,请计算其下属 jj 的数量满足 p(j) > p(i)p(j)>p(i) 。

输入输出格式

输入格式:

 

The first line of input contains NN .

The next NN lines of input contain the proficiency ratings p(1) \ldots p(N)p(1)p(N) for the cows. Each is a distinct integer in the range 1 \ldots 1,000,000,00011,000,000,000 .

The next N-1N1 lines describe the manager (parent) for cows 2 \ldots N2N . Recall that cow 1 has no manager, being the president.

输入的第一行包括一个整数 NN 。

接下来的 NN 行包括奶牛们的能力指数 p(1) \cdots p(N)p(1)p(N) . 保证所有数互不相同,在区间 1 \cdots 10^91109 之间。

接下来的 N-1N1 行描述了奶牛 2 \cdots N2N 的上司(双亲节点)的编号。再次提醒,1 号奶牛作为总裁,没有上司。

 

输出格式:

 

Please print NN lines of output. The ii th line of output should tell the number of subordinates of cow ii with higher proficiency than cow ii .

输出包括 NN 行。输出的第 ii 行应当给出有多少奶牛 ii 的下属比奶牛 ii 能力高。

 

输入输出样例

输入样例#1: 复制
5
804289384
846930887
681692778
714636916
957747794
1
1
2
3
输出样例#1: 复制
2
0
1
0
0

总结:线段树合并裸题
dfs时,将每一颗子树对应的权值线段树合并到当前节点,然后查询
并查集维护连通性
#include <bits/stdc++.h>
using namespace std;

const int maxn = 4e5 + 7;
int n, m, a[maxn], b[maxn], tot, cnt = 1;
int head[maxn], sum;
struct Node {
	int v, nxt;
} G[maxn];
struct V {
	int v, ls, rs;
} t[maxn];

int f[maxn], rt[maxn], ans[maxn];
void ins(int u, int v) {
	G[cnt] = (Node) {v, head[u]}; head[u] = cnt++;
}
int find(int x) {
	return f[x] == x ?x :f[x] = find(f[x]);
} 
void Modify(int &o, int l, int r, int w) {
	if(!o) o = ++tot; t[o].v++;
	if(l == r) return;
	int mid = (l + r) >> 1;
	if(w <= mid) Modify(t[o].ls, l, mid, w);
	else Modify(t[o].rs, mid + 1, r, w);
}
void Merge(int &r1, int r2) {
	if(!r1) {r1 = r2; return;}
	if(!r2) return;
	t[r1].v += t[r2].v;
	Merge(t[r1].ls, t[r2].ls); Merge(t[r1].rs, t[r2].rs);
}
int Query(int o, int l, int r, int ql, int qr) {
	if(ql <= l && r <= qr) return t[o].v;
	int mid = (l + r) >> 1, res = 0;
	if(ql <= mid) res += Query(t[o].ls, l, mid, ql, qr);
	if(qr > mid) res += Query(t[o].rs, mid + 1, r, ql, qr);
	return res;
} 
void dfs(int x, int fa) {
	for (int i = head[x]; i; i = G[i].nxt) {
		int v = G[i].v; if(v == fa) continue;
		dfs(v, x); int r1 = find(x), r2 = find(v);
		if(r1 != r2) {
			f[r2] = r1; Merge(rt[r1], rt[r2]);
		}
	}
	ans[x] = Query(rt[find(x)], 1, sum, a[x] + 1, sum);
}
int main() {
	scanf("%d", &n);
	for (int i = 1; i <= n; ++i) {
		scanf("%d", &a[i]); b[i] = a[i];
	}
	for (int i = 2; i <= n; ++i) {
		int x; scanf("%d", &x); ins(x, i); ins(i, x);
	}
	sort(b + 1, b + n + 1); sum = unique(b + 1, b + n + 1) - b - 1;
	for (int i = 1; i <= n; ++i) a[i] = lower_bound(b + 1, b + sum + 1, a[i]) - b;
	for (int i = 1; i <= n; ++i) {
		Modify(rt[f[i] = i], 1, sum, a[i]);
	} dfs(1, 0);
	for (int i = 1; i <= n; ++i) printf("%d\n", ans[i]);
	return 0;
}
 
  

  

 

猜你喜欢

转载自www.cnblogs.com/oi-forever/p/9199239.html