sscanf和sprintf的应用

问题

1108 Finding Average (20 分)
The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.
Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
结尾无空行
Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
结尾无空行
Sample Input 2:

2
aaa -9999
结尾无空行
Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined
结尾无空行

思路

char[]存储原始输入,然后利用sscanf将其转化成double型(控制只保留两位小数),再使用sprintf将上一步得到的double型数据转化成char[]。逐个字符与原始的char[]进行对比,如果不相等,说明该数不合法,置flag为false。所以不合法的情况一共三种,flag为false, 转化得到的double型数据大于1000,得到的double型数据小于-1000。

代码

#include <bits/stdc++.h>
using namespace std;



int main() {
    
    
    int n,count = 0;
    double sum = 0.0,ave,temp;
    cin>>n;
    char a[50],b[50];
    for (int i = 0; i < n; ++i) {
    
    
        scanf("%s",a);
        sscanf(a,"%lf",&temp);
        sprintf(b,"%.2f",temp);
        bool flag = true;
        for (int j = 0; j < strlen(a); ++j) {
    
    
            if(a[j] != b[j]) {
    
    
                flag = false;
                break;
            }
        }
        if(flag == false || temp < -1000 || temp > 1000){
    
    
            printf("ERROR: %s is not a legal number\n",a);
            continue;
        }else{
    
    
            sum += temp;
            count++;
        }
    }
    ave = sum/count;
    if(count == 1){
    
    
        printf("The average of 1 number is %.2f",ave);
    }else if(count == 0){
    
    
        printf("The average of 0 numbers is Undefined");
    }else{
    
    
        printf("The average of %d numbers is %.2f",count,ave);
    }
    return 0;
}

总结

sscanf() – 从一个字符串中读进与指定格式相符的数据
sprintf() – 字符串格式化命令,主要功能是把格式化的数据写入某个字符串中

猜你喜欢

转载自blog.csdn.net/qq_19272233/article/details/119968691