1090 Highest Price in Supply Chain (25 分)(树的遍历,dfs)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤10

5

), the total number of the members in the supply chain (and hence they are numbered from 0 to N−1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number S

i

is the index of the supplier for the i-th member. S

root

for the root supplier is defined to be −1. All the numbers in a line are separated by a space.

扫描二维码关注公众号,回复: 15257085 查看本文章

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 10

10

.

Sample Input:

9 1.80 1.00

1 5 4 4 -1 4 5 3 6

Sample Output:

1.85 2

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <string>
#include <cctype>
#include <string.h>
#include <cstdio>
#include <unordered_set>
using namespace std;
int n,maxdepth=0,maxnum=0,temp,root;
vector<int> v[100010];
void dfs(int index,int depth){
    if(v[index].size()==0){
        if(depth>maxdepth){
            maxdepth=depth;
            maxnum=1;
        }else if(depth==maxdepth){
            maxnum++;
        }
        return;
    }
    for(int i=0;i<v[index].size();i++)
        dfs(v[index][i],depth+1);
}
int main(){
    double p,r;
    cin>>n>>p>>r;
    r/=100;
    for(int i=0;i<n;i++){
        cin>>temp;
        if(temp==-1)
            root=i;
        else
            v[temp].push_back(i);
    }
    dfs(root,0);
    printf("%.2f %d",p*pow(1+r,maxdepth),maxnum);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42068614/article/details/87876036