数据结构实验之排序一:一趟快排

数据结构实验之排序一:一趟快排

Time Limit: 1000MS  Memory Limit: 65536KB

Problem Description

给定N个长整型范围内的整数,要求输出以给定数据中第一个数为枢轴进行一趟快速排序之后的结果。

 

Input

连续输入多组数据,每组输入数据第一行给出正整数N(N < = 10^5),随后给出N个长整型范围内的整数,数字间以空格分隔。

Output

输出一趟快速排序后的结果,数字间以一个空格间隔,行末不得有多余空格。

Example Input

8
49 38 65 97 76 13 27 49

Example Output

27 38 13 49 76 97 65 49

#include <iostream>
using namespace std;
int a[100010];

void qsort(int low,int high)
{
    int key=a[low];
    while(low<high)//没有=
    {
        while(low<high&&a[high]>=key)
            high--;
        a[low]=a[high];
        while(low<high&&a[low]<=key)
            low++;
        a[high]=a[low];
    }
    a[low]=key;
}

int main()
{
    int n;
    while(cin>>n)
    {
        for(int i=0;i<n;i++)
            cin>>a[i];
        qsort(0,n-1);
        for(int i=0;i<n;i++)
        {
            if(i==n-1)
                cout<<a[i]<<endl;
            else
                cout<<a[i]<<" ";
        }
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/matrix97/article/details/53676186
今日推荐