[AtCoder ABC096]D - Five, Five Everywhere(构造)

D - Five, Five Everywhere

Time limit : 2sec / Memory limit : 256MB
Score: 400 points

Problem Statement

Print a sequence a 1 , a 2 , , a N whose length is N that satisfies the following conditions:

  • a i ( 1 i N ) is a prime number at most 55 555 .
  • The values of a 1 , a 2 , , a N are all different.
  • In every choice of five different integers from a 1 , a 2 , , a N , the sum of those integers is a composite number.
    If there are multiple such sequences, printing any of them is accepted.

Notes

An integer N not less than 2 is called a prime number if it cannot be divided evenly by any integers except 1 and N , and called a composite number otherwise.

Constraints

  • N is an integer between 5 and 55 (inclusive).

Input

Input is given from Standard Input in the following format:

N

Output

Print N numbers a 1 , a 2 , a 3 , , a N in a line, with spaces in between.

Sample Input 1

5

Sample Output 1

3 5 7 11 31

Let us see if this output actually satisfies the conditions.
First, 3, 5, 7, 11 and 31 are all different, and all of them are prime numbers.
The only way to choose five among them is to choose all of them, whose sum is a 1 + a 2 + a 3 + a 4 + a 5 = 57 , which is a composite number.
There are also other possible outputs, such as 2 3 5 7 13, 11 13 17 19 31 and 7 11 5 31 3.

Sample Input 2

6

Sample Output 2

2 3 5 7 11 13

2 , 3 , 5 , 7 , 11 , 13 are all different prime numbers.
2 + 3 + 5 + 7 + 11 = 28 is a composite number.
2 + 3 + 5 + 7 + 13 = 30 is a composite number.
2 + 3 + 5 + 11 + 13 = 34 is a composite number.
2 + 3 + 7 + 11 + 13 = 36 is a composite number.
2 + 5 + 7 + 11 + 13 = 38 is a composite number.
3 + 5 + 7 + 11 + 13 = 39 is a composite number.
Thus, the sequence `2 3 5 7 11 13“ satisfies the conditions.

Sample Input 3

8

Sample Output 3

2 5 7 13 19 37 67 79

解题思路

比赛时居然没想出来,被可恶的样例解释带偏了…
要求给出一个全是质数的数列,使得任取五个数的和都是合数
既然这样,我们不妨让所有数的个位都是1,很容易证明在 [ 5 , 55555 ] 中可以找出至少 55 个这样的个位是1的质数
那么,任意5个数的和的个位就一定是5了——那就一定是合数了
oops…


Code

#include<cstdio>

using namespace std;

int n;

bool isPrime(int x){
    for(int i = 2; i * i <= x; i++)
        if(x % i == 0)
            return false;
    return true;
}

int main(){
    scanf("%d", &n);
    for(int i = 11; n; i += 10){
        if(isPrime(i)){
            printf("%d ", i);
            n--;
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/phantomagony/article/details/80210689