Bee

题目描述

In Africa there is a very special species of bee. Every year, the female bees of such species give birth to one male bee, while the male bees give birth to one male bee and one female bee, and then they die!

Now scientists have accidentally found one "magical female bee" of such special species to the effect that she is immortal, but still able to give birth once a year as all the other female bees. The scientists would like to know how many bees there will be after N years. Please write a program that helps them find the number of male bees and the total number of all bees after N years. 

输入

Each line of input contains an integer N (≥ 0). Input ends with a case where N = -1. (This case should NOT be processed.) 

输出

Each line of output should have two numbers, the first one being the number of male bees after N years, and the second one being the total number of bees after N years. (The two numbers will not exceed 232.) 

样例输入

1
3
-1

样例输出

1 2
4 7
#include<iostream>
#include<math.h>
using namespace std;

int main()
{
    int n,i;
    cin>>n;
    while(n>-1)
    {
     int a=1,b=0,c,d;
        for(i=0;i<n;i++)
        {
            c=1+b;
            d=a+b;
            a=c;
            b=d;
        }
        cout<<b<<" "<<a+b<<endl;
        cin>>n;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/i_silence/article/details/80496364
Bee