并查集+欧拉道路

problem

Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us. There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ‘acm’ can be followed by the word ‘motorola’. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door.

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number N that indicates the number of plates (1 ≤ N ≤ 100000). Then exactly N lines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters ‘a’ through ‘z’ will appear in the word. The same word may appear several times in the list.

Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times. If there exists such an ordering of plates, your program should print the sentence ‘Ordering is possible.’. Otherwise, output the sentence ‘The door cannot be opened.’

Sample Input

3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok

Sample Output

The door cannot be opened.
Ordering is possible.
The door cannot be opened.

题解

使用并查集判断图是否连通,再判断是否满足有向图存在欧拉道路的条件.

图类型 欧拉道路 欧拉回路
有向图 只包含两个奇度数节点 不包含奇度数节点
无向图 基图联通 && 最多两个点出度!=入度 &&一个点 入度-出度=1 && 另一个点 出度- 入度=1 连通图 && 图中所有点的度数都是偶数
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <vector> 
#include <algorithm>
using namespace std;
const int maxn=1e5+10;
string s[maxn];
int vis[305];//记录字母是否出现
int pre[305];
int mp[305];
int t,n;
int find(int x)
{
    
    
	return x==pre[x]?x:find(pre[x]);
}
void merge(int a,int b)
{
    
    
	int x=find(a);
	int y=find(b);
	if(x!=y)
	{
    
    
		pre[y]=x;
	}
}
int main()
{
    
    
	cin>>t;
	while(t--)
	{
    
    
		cin>>n;
		memset(vis,0,sizeof(vis));
		memset(mp,0,sizeof(mp));
		for(int i='a';i<='z';i++) pre[i]=i;
		for(int i=0;i<n;i++)
		{
    
    
			cin>>s[i];
			char a=s[i][0],b=s[i][s[i].length()-1];
			vis[a]=1,vis[b]=1;
			mp[a]++,mp[b]--;
			merge(a,b); 
		}
		int g=0;
		vector<int> q;
		for(int i='a';i<='z';i++)
		{
    
    
			if(pre[i]==i&&vis[i]) g++;
			if(vis[i]&&mp[i]!=0) q.push_back(mp[i]);
		}
	//	printf("%d****\n",g);
		if(g==1)
		{
    
    
			if(q.size()==0||(q.size()==2&&(q[0]==-1||q[0]==1)&&(q[1]==-1||q[1]==1))) 
			{
    
    
				printf("Ordering is possible.\n");
			}
			else printf("The door cannot be opened.\n");
		}
		else printf("The door cannot be opened.\n");
	}
}

猜你喜欢

转载自blog.csdn.net/csx_zzh/article/details/115250625